Programy z VS2010 C# a Windows98

0

Czy da się jakoś skompilować program napisany w VS2010 C# tak aby można go było uruchomić na Windows98? Na Win98 nie moge zainstalować Framework 4.0.

Nie pamiętam już gdzie ale gdzieś widziałem że rzekomo da się z poziomu VS2010 .NET 4.0 kompilować programy tak aby można je było uruchamiać po zainstalowaniu tylko Framework'a 2.0 albo 3.5, jeżeli to prawda to prosiłbym o wskazówki jak to zrobić.

Sprawa przedstawia się tak, że mam zainstalowane VS2010, napisany program działa na komputerach z WindowsXP po zainstalowaniu na nich Framework 4.0, ale potrzebuje uruchamiać ten sam program również na komputerach pracujących pod Win98, a Win98 nie przyjmuje (nie da się zainstalować na nim) Framework 4.0.

Czy jest jakiś sposób aby nie było konieczne odinstalowywanie VS2010 i zainstalowanie VS2005 i kompilowanie na nim tego projektu z VS2010? Czy w ogóle ten sposób coś da?

PS. W programie używam raczej podstaw C#, raczej nic z nowości zaimlementowanych tylko w C#4.0.

1

Project->Properties->Application->Target Framework

1

Ostatnia wersja .Net działająca na Win98 to 2.0.
Nie próbowałem z VS2010, ale program pisany pod VS2008 po pewnych poprawkach na Win98 działał.

1

Zajrzałem do MSa i stoi że 98 to ino do v2 ma .NET'a więc takowego wybierz w Targetku.

0

Dzięki wielkie za podpowiedzi , właściwie jak "sperling" naprowadził mnie gdzie to jest to już metodą prób i błędów doszedłem ze .NET v3.5 to za wysoko na 98 i skompilowałem program w v.2.0 - tak jak przypuszczałem z .NET v4.0 niewiele używałem nowości właściwie poprawki programu po przełączeniu na kompilowanie z Framework v.2.0 ograniczyło się do wykreślenia paru dodawanych w projekcie domyslnie przestrzeni nazw m.in. system.xml.linq

PS. Przy okazji już wiem gdzie się ustawia ikonkę programu i inne takie ;)

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0