Emulator Android Studio vs Ryzek 5 1600

Odpowiedz Nowy wątek
2019-02-25 23:00
0

Hej, toczę beznadziejna batalię z Android Studio, jestem posiadaczem Ryzen 5 1600, w Biosie posiadam włączoną wirtualizację.
Sprawdzając stan Hyper-V dostaję informacje o tym, że wszystko jest aktywne.
Ale za nic nie udaje mi sie odpalić emulatora.
Lecz mimo wszystko za każdą próbą odpalenia aplikacji dostaję:

22:59 Emulator: emulator: ERROR: x86 emulation currently requires hardware acceleration!

22:59 Emulator: Process finished with exit code 1

Czy mielibyście jakieś porady co mógłbym dodatkowo zrobić by łaskawie zaczęło to działać? Nie licząc ściągnięcia jakiegoś arma?

PS C:\WINDOWS\system32> Get-WindowsOptionalFeature -Online -FeatureName *Hyper-V*

FeatureName      : Microsoft-Hyper-V-All
DisplayName      : Hyper-V
Description      : Udostępnia usługi i narzędzia do zarządzania na potrzeby tworzenia i uruchamiania maszyn wirtualnych
                    oraz ich zasobów.
RestartRequired  : Possible
State            : Enabled
CustomProperties :

FeatureName      : Microsoft-Hyper-V
DisplayName      : Platforma Hyper-V
Description      : Udostępnia usługi umożliwiające tworzenie maszyn wirtualnych i ich zasobów oraz zarządzanie nimi.
RestartRequired  : Possible
State            : Enabled
CustomProperties :

FeatureName      : Microsoft-Hyper-V-Tools-All
DisplayName      : Narzędzia do zarządzania funkcją Hyper-V
Description      : Zawiera graficzny interfejs użytkownika i narzędzia wiersza polecenia umożliwiające zarządzanie funk
                   cją Hyper-V.
RestartRequired  : Possible
State            : Enabled
CustomProperties :

FeatureName      : Microsoft-Hyper-V-Management-PowerShell
DisplayName      : Moduł funkcji Hyper-V dla programu Windows PowerShell
Description      : Zawiera polecenia cmdlet programu Windows PowerShell umożliwiające zarządzanie funkcją Hyper-V.
RestartRequired  : Possible
State            : Enabled
CustomProperties :

FeatureName      : Microsoft-Hyper-V-Management-Clients
DisplayName      : Narzędzia do zarządzania funkcją Hyper-V za pomocą graficznego interfejsu użytkownika
Description      : Zawiera przystawkę Menedżer funkcji Hyper-V i narzędzie Połączenie z maszyną wirtualną.
RestartRequired  : Possible
State            : Enabled
CustomProperties :

FeatureName      : Microsoft-Hyper-V-Hypervisor
DisplayName      : Funkcja hypervisor (Hyper-V)
Description      : Udostępnia funkcję hypervisor (Hyper-V).
RestartRequired  : Possible
State            : Enabled
CustomProperties :

FeatureName      : Microsoft-Hyper-V-Services
DisplayName      : Usługi funkcji Hyper-V
Description      : Udostępnia usługi umożliwiające tworzenie maszyn wirtualnych i ich zasobów oraz zarządzanie nimi.
RestartRequired  : Possible
State            : Enabled
CustomProperties :
I jak planujesz więcej kodzic to ogarnij sobie Linuxa. Mniejszy ból głowy że wszystkim. - dbCooper 2019-02-26 02:01
Patrzył chyba "wszystko" ze stacka, ale chyba znalazłem przyczynę, sprawdzę w godzinach wieczornych. A co do Linuxa, wystarczy wirtualna maszyna czy warto chociażby bootować go z pena? Czy trzeba aż drugi system instalować? @dbCooper - Sebixxu 2019-02-26 08:44
Jak masz duzy dysk to polecam po prostu dwa systemy. Ja tak mam w domu i sprawdza sie bardzo dobrze. - dbCooper 2019-02-26 09:41

Pozostało 580 znaków

2019-02-26 08:48
0

Tak jak napisał @WeiXiao, zainstaluj HAXM.

Mam prześwity pamięci że jeśli zainstalujesz linuxa na maszynie wirtualnej to nie będziesz mógł uruchomić kolejnej z jej poziomu - emulatora.

Pozostało 580 znaków

2019-02-26 08:48
0
lubie_programowac napisał(a):

Tak jak napisał @WeiXiao, zainstaluj HAXM.

Mam prześwity pamięci że jeśli zainstalujesz linuxa na maszynie wirtualnej to nie będziesz mógł uruchomić kolejnej z jej poziomu - emulatora.

HAXM działa pod AMD?

Pozostało 580 znaków

2019-02-26 11:36
0

Zgodnie z https://stackoverflow.com/que[...]valent-for-amd-on-windows-os# Posting a new answer since it is 2019. w styczniu tego roku coś się zmieniło - doczytaj. Jeśli nie będzie działać można spróbować zainstalować GenyMotion.

Pozostało 580 znaków

2019-03-03 11:31
1

Wszystko udało mi się naprawić, jak się okazało, jakimś cudem ominęły mnie aktualizacje Windowsa i z racji starszej wersji, nie dawało się włączyć funkcji w systemie: "Platforma funkcji Hypervisor systemu Windows", po aktualizacji Win i włączeniu tej funkcji udało się uruchomić emulator i działa na prawdę fajnie. Dziękuje wszystkim za linki i pomoc, naprowadziliście mnie na powód problemu :)

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0