Wątek przeniesiony 2019-08-20 10:35 z przez Patryk27.

Co tu jest nie tak?

2019-08-20 08:47
0

Taka komenda

$sql = "INSERT INTO nazwa-tabeli VALUES ('".$_GET["wartosc1"]."','".$_GET["wartosc2"]."','".$_GET["wartosc3"]."')";

Po egzekucji skryptu wstawia wiersz do tabeli, ale pusty. Czemu nie wstawia danych z pól formularza?

@Patryk27: meh, byłeś 4s szybszy :/ - superdurszlak 2019-08-20 08:51

Pozostało 580 znaków

2019-08-20 08:53
0

Sprawdź czy $_GET["wartosc1"], $_GET["wartosc2"], $_GET["wartosc3"] nie są przypadkiem puste ;)


"Chodzenie po wodzie i tworzenie oprogramowania wg specyfikacji są łatwe, o ile woda i specyfikacja są zamrożone" - Edward V. Berard

Pozostało 580 znaków

2019-08-20 08:55
0
Madaoo napisał(a):

Sprawdź czy $_GET["wartosc1"], $_GET["wartosc2"], $_GET["wartosc3"] nie są przypadkiem puste ;)

nie jest na 100%

Pozostało 580 znaków

2019-08-20 08:56
0

spróbuj

$sql = 'INSERT INTO nazwa-tabeli VALUES ("'.$_GET["wartosc1"].'", "'.$_GET["wartosc2"].'", "'.$_GET["wartosc3"].'")';

albo

$sql = 'INSERT INTO nazwa-tabeli VALUES("'.$_GET['wartosc1'].'", "'.$_GET['wartosc2'].'", "'.$_GET['wartosc3'].'")';
edytowany 2x, ostatnio: Luu888, 2019-08-20 08:59

Pozostało 580 znaków

2019-08-20 09:02
0
Luu888 napisał(a):

spróbuj

$sql = 'INSERT INTO nazwa-tabeli VALUES ("'.$_GET["wartosc1"].'", "'.$_GET["wartosc2"].'", "'.$_GET["wartosc3"].'")';

albo

$sql = 'INSERT INTO nazwa-tabeli VALUES("'.$_GET['wartosc1'].'", "'.$_GET['wartosc2'].'", "'.$_GET['wartosc3'].'")';

Również nie działa jak powinno

Pozostało 580 znaków

Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0