npm run dev nie wstaje

Odpowiedz Nowy wątek
2019-01-14 18:59
0

Robiłem już chyba wszystko co się da, reinstalowałem node'a, kasowałem zawartość folderu npm - npm-cache i za każdym razem gdy chcę postawić nowy projekt Vue to dostaję:

PS C:\Users\User\Desktop\Front\VueJS\my-vue-app2> npm run dev

> [email protected] dev C:\Users\User\Desktop\Front\VueJS\my-vue-app2
> webpack-dev-server --inline --progress --config build/webpack.dev.conf.js

internal/modules/cjs/loader.js:583
    throw err;
    ^

Error: Cannot find module 'webpack/bin/config-yargs'

    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:581:15)
    at Function.Module._load (internal/modules/cjs/loader.js:507:25)
    at Module.require (internal/modules/cjs/loader.js:637:17)
    at require (internal/modules/cjs/helpers.js:22:18)
    at Object.<anonymous> (C:\Users\User\node_modules\webpack-dev-server\bin\webpack-dev-server.js:54:1)
    at Module._compile (internal/modules/cjs/loader.js:689:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:700:10)
    at Module.load (internal/modules/cjs/loader.js:599:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:538:12)
    at Function.Module._load (internal/modules/cjs/loader.js:530:3)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] dev: `webpack-dev-server --inline --progress --config build/webpack.dev.conf.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] dev script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

Po usunięciu node'a i folderów projekt stawiam poprzez komendy:

npm install -g vue-cli
vue init webpack my-vue-app

wtedy się pluje, że nie ma webpack'a, więc daję:

npm install -g webpack i npm install -g webpack-dev-server No i dalej to już leci error jak wyżej. Proszę o pomoc.

package.json w utworzonym projekcie:

{
  "name": "my-vue-app2",
  "version": "1.0.0",
  "description": "A Vue.js project",
  "author": "ww",
  "private": true,
  "scripts": {
    "dev": "webpack-dev-server --inline --progress --config build/webpack.dev.conf.js",
    "start": "npm run dev",
    "build": "node build/build.js"
  },
  "dependencies": {
    "vue": "^2.5.2",
    "vue-router": "^3.0.1"
  },
  "devDependencies": {
    "autoprefixer": "^7.1.2",
    "babel-core": "^6.22.1",
    "babel-helper-vue-jsx-merge-props": "^2.0.3",
    "babel-loader": "^7.1.1",
    "babel-plugin-syntax-jsx": "^6.18.0",
    "babel-plugin-transform-runtime": "^6.22.0",
    "babel-plugin-transform-vue-jsx": "^3.5.0",
    "babel-preset-env": "^1.3.2",
    "babel-preset-stage-2": "^6.22.0",
    "chalk": "^2.0.1",
    "copy-webpack-plugin": "^4.0.1",
    "css-loader": "^0.28.0",
    "extract-text-webpack-plugin": "^3.0.0",
    "file-loader": "^1.1.4",
    "friendly-errors-webpack-plugin": "^1.6.1",
    "html-webpack-plugin": "^2.30.1",
    "node-notifier": "^5.1.2",
    "optimize-css-assets-webpack-plugin": "^3.2.0",
    "ora": "^1.2.0",
    "portfinder": "^1.0.13",
    "postcss-import": "^11.0.0",
    "postcss-loader": "^2.0.8",
    "postcss-url": "^7.2.1",
    "rimraf": "^2.6.0",
    "semver": "^5.3.0",
    "shelljs": "^0.7.6",
    "uglifyjs-webpack-plugin": "^1.1.1",
    "url-loader": "^0.5.8",
    "vue-loader": "^13.3.0",
    "vue-style-loader": "^3.0.1",
    "vue-template-compiler": "^2.5.2",
    "webpack": "^3.6.0",
    "webpack-bundle-analyzer": "^2.9.0",
    "webpack-dev-server": "^2.9.1",
    "webpack-merge": "^4.1.0"
  },
  "engines": {
    "node": ">= 6.0.0",
    "npm": ">= 3.0.0"
  },
  "browserslist": [
    "> 1%",
    "last 2 versions",
    "not ie <= 8"
  ]
}
edytowany 1x, ostatnio: slayer9, 2019-01-14 19:01

Pozostało 580 znaków

2019-01-14 21:48
0

Przerzuciłem się na yarna, teraz jest jeszcze gorzej:

PS C:\Users\User\Desktop> vue init webpack my-vue-app
At C:\Users\User\AppData\Local\Yarn\bin\vue.ps1:5 char:13
+     *CYGWIN*) basedir=`cygpath -w "$basedir"`;;

+             ~
Unexpected token ')' in expression or statement.
At C:\Users\User\AppData\Local\Yarn\bin\vue.ps1:8 char:3
+ if [ -x "$basedir/pwsh" ]; then
+   ~
Missing '(' after 'if' in if statement.
At C:\Users\User\AppData\Local\Yarn\bin\vue.ps1:8 char:5
+ if [ -x "$basedir/pwsh" ]; then
+     ~
Missing type name after '['.
At C:\Users\User\AppData\Local\Yarn\bin\vue.ps1:9 char:20
+   "$basedir/pwsh"  "$basedir/../Data/global/node_modules/.bin/vue.ps1" "[email protected]"
+                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Unexpected token '"$basedir/../Data/global/node_modules/.bin/vue.ps1"' in expression or statement.
At C:\Users\User\AppData\Local\Yarn\bin\vue.ps1:9 char:72
+   "$basedir/pwsh"  "$basedir/../Data/global/node_modules/.bin/vue.ps1" "[email protected]"
+                                                                        ~~~~
Unexpected token '"[email protected]"' in expression or statement.
    + CategoryInfo          : ParserError: (:) [], ParseException
    + FullyQualifiedErrorId : UnexpectedToken

Ktoś miał podobnie ?

Pozostało 580 znaków

2019-01-14 21:51
0

Możliwe że npm i -D webpack-cli załatwi sprawę.

Pozostało 580 znaków

2019-01-14 22:26
0

Próbowałem to też i nic.

Pozostało 580 znaków

2019-01-15 08:21
1
npm i -SD webpack-cli

Powinien pomóc. Może problem z wersjami?
Masz jakiś konkretny powód czemu nie używasz najnowszego webpacka?

Btw. masz na pewno poprawną wersję node'a (>= 6.11.5)?;

edytowany 2x, ostatnio: OverMorda, 2019-01-15 08:23

Pozostało 580 znaków

2019-01-15 09:29
0

Obstawiam starą wersję Node. U mnie pobierało wszytko co potrzeba (łącznie z webpackiem) przy instalacji vue-cli, bo przecież vue-cli ma go w zależnościach.


Pozostało 580 znaków

2019-01-15 17:34
0

@OverMorda, @siloam

Tak jak mówiłem: npm i -SD webpack-cli nie powoduje nic, dalej ten error leci. Co do starej wersji node'a -raczej odpada, reinstalowałem noda korzystając z instalki z oficjalnej strony.

Masz jakiś konkretny powód czemu nie używasz najnowszego webpacka?

Nie mam pojęcia, po wywaleniu wszystkich pakietów npm'a z dysku wpisałem npm install -g webpack i cały czas korzystałem z tej wersji którą mi pobrał.

Btw. masz na pewno poprawną wersję node'a (>= 6.11.5)?;

Pobrany stąd: https://nodejs.org/en/

Obstawiam starą wersję Node. U mnie pobierało wszytko co potrzeba (łącznie z webpackiem) przy instalacji vue-cli, bo przecież vue-cli ma go w zależnościach.

No właśnie a u mnie po totalnym cleanie wszystkiego i reinstallu npm na czysto, gdy wpisuję npm install -g vue-cli i vue init webpack my-vue-app a potem odpalam projekt to pluje się, że nie rozumie polecenia "webpack-dev-server". Czyli nie pobrał mi tych paczek, a jak doinstaluję, manualnie za pomocą npm install to wychodzi na to, że mam lipę z wersjami, bo leci ten error, który napisałem w pierwszym poście.

Btw a na to macie jakiś pomysł ?

C:\Users\User\Desktop> vue
At C:\Users\User\AppData\Local\Yarn\bin\vue.ps1:5 char:13
+     *CYGWIN*) basedir=`cygpath -w "$basedir"`;;
+             ~
Unexpected token ')' in expression or statement.
At C:\Users\User\AppData\Local\Yarn\bin\vue.ps1:8 char:3
+ if [ -x "$basedir/pwsh" ]; then
+   ~
Missing '(' after 'if' in if statement.
At C:\Users\User\AppData\Local\Yarn\bin\vue.ps1:8 char:5
+ if [ -x "$basedir/pwsh" ]; then

+     ~
Missing type name after '['.
At C:\Users\User\AppData\Local\Yarn\bin\vue.ps1:9 char:20
+   "$basedir/pwsh"  "$basedir/../Data/global/node_modules/.bin/vue.ps1" "[email protected]"
+                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Unexpected token '"$basedir/../Data/global/node_modules/.bin/vue.ps1"' in expression or statement.
At C:\Users\User\AppData\Local\Yarn\bin\vue.ps1:9 char:72
+   "$basedir/pwsh"  "$basedir/../Data/global/node_modules/.bin/vue.ps1" "[email protected]"
+                                                                        ~~~~
Unexpected token '"[email protected]"' in expression or statement.
    + CategoryInfo          : ParserError: (:) [], ParseException
    + FullyQualifiedErrorId : UnexpectedToken

Po wywaleniu npma i zainstalowaniu yarn jak wpisuję do powershella vue to wychodzi na to, że w którejś z bibliotek brakuje nawiasów i też mam związane ręce wtf..

edytowany 1x, ostatnio: slayer9, 2019-01-15 17:38

Pozostało 580 znaków

2019-01-15 17:44
1

https://github.com/mzgoddard/jest-webpack/issues/27 - wygląda jak Twój problem

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0