Java Spark działa na niższej wersji ?

Odpowiedz Nowy wątek
2018-12-30 21:41
0

Witam, otóż chciałem zacząć naukę sparka zaczynając z tym tutorialem: http://sparkjava.com/tutorials/maven-setup
I kiedy dodaje biblioteke w pom.xml:

<dependency> <groupid>com.sparkjava</groupid> <artifactid>spark-core</artifactid> <version>2.5</version> </dependency>

wyskakuje mi błąd:
Exception in thread "Thread-0" java.lang.NoClassDefFoundError: javax/servlet/Filter
at spark.embeddedserver.EmbeddedServers.initialize(EmbeddedServers.java:40)
A gdy zmienie wersje na 2.2 program działa, wie ktoś może jak uruchomić to na nowszej wersji ?

Pozostało 580 znaków

2018-12-31 00:43
1

Gwarantuję że aktualna wersja działa bez problemu (korzystałem godzinę temu używając gradle)
Rzuć okiem tutaj na numer wersji.

Jest też szansa, że Maven czegoś sobie nie pobrał/coś zgubił - warto się upewnić że wszystko co potrzebne zostało pobrane.


edytowany 2x, ostatnio: Burdzi0, 2018-12-31 00:45

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0