Java 3D - nie mogę zacząć pracy

0

Witam,
korzystam z Ubuntu 10.10. Przez "Centrum oprogramowania" zainstalowałem Java 3D API w wersji 1.5.2.
Znalazłem w sieci prosty program do wyświetlania kwadratu:

import com.sun.j3d.utils.*;

public class J3D {

public J3D()

{

   SimpleUniverse universe = new SimpleUniverse();

   BranchGroup group = new BranchGroup();

   group.addChild(new ColorCube(0.3));

   universe.getViewingPlatform().setNominalViewingTransform();

   universe.addBranchGraph(group); 

}

public static void main( String[] args ) { 

   new J3D();

}

} 

Jednak Eclipse krzyczy mi, że w 1. linijce nie może znaleźć pakietu do zaimportowania. Jak to naprawić?
Co radzicie?
Pozdrawiam

0

W ustawieniach projektu -Java Build path - Libraries - Add External Jars dodaj z katalogu /usr/share/java j3dcore.jar oraz j3dutils.jar i po kłopocie.
Gdyby jeszcze wywalało error przy kompilacji związany z nieznalezieniem biblioteki do wektorów dodaj z tego samego katalogu vecmath.jar

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0