Maven pierwsze kroki...

Odpowiedz Nowy wątek
2011-07-27 14:30
0

Witam....
próbuje bawić się maven'em i natrafiłem na barierę :/
Robię po kolei ze strony Maven.

Wszystko jest ok do czasu w którym mam zrobić deploy na server.
wywala mi błąd przy kompilacji przy dodaniu pluginu :

                        <plugin>
                                <groupId>org.codehaus.mojo</groupId>
                                <artifactId>tomcat-maven-plugin</artifactId>
                                <configuration>
                                        <a href="http://localhost:28280/manager">http://localhost:28280/manager</a>
                                        <server>tomcat55</server>
                                        <warFile>${project.build.directory}/${project.build.finalName}.war</warFile>
                                </configuration>
                        </plugin>

i tak :
http://localhost:28280/manager - nie zmieniam (chociaż próbowałem też przestawić na http://localhost:8080/)
tomcat55 - zmieniłem na tomcat6
project.build.directory - zmieniłem na miejsce w którym utwortzyłem mój projekt mavena w moim przypadku "C:\Maven\"
project.build.finalName - tutaj zamieniłem na nazwę pliku war (który znajduje się w katalogu \target) czyli w moim przypadku "Maven-0.1"

i nie działa....
tomcata ustawiłem tak :
Zmienne użytkownika
CATALINA_BASE - C:\atomcat6\bin
Zmienne systemowe :
CATALINA_HOME - C:\atomcat6
JAVA_HOME - C:\Program Files\Java\jdk1.6.0_21
PATH - C:\amaven\bin;C:\Program Files\Java\jdk1.6.0_21\bin;C:\amaven\bin

Nadmienie że jak przez cmd próbuje uruchomić tomcata to nie chce ruszyć....natomiast w netbeansie i w eclipsie jest ok..

Ps. Czym się różni zmienna użytkownika od zmiennej systemowej? Tym że systemowa jest dla wszystkich użytkowników, a zmienna użytkownika tylko dla danego usera?

Pozdr...

Pozostało 580 znaków

2011-07-27 15:27
0

Tomcat ma domyślnie wyłąconych userów do deploya - edytuj tomcat-users.xml

spróbuj

<plugin> <groupid>org.codehaus.mojo</groupid> <artifactid>tomcat-maven-plugin</artifactid> <configuration> <url>${tomcatUrl}</url> <path>${path}</path> <username>${tomcatUser}</username> <password>${tomcatPass}</password> </configuration> </plugin>

Pozostało 580 znaków

2011-07-27 21:53
0

próbowałem i tak i tak...nadal nic :/
zauważyłem także coś dziwnego - w katalogu .m2/ nie mam settings.xml :o wtf
plik ten znajduje się jedynie w katalogu maven/conf

edytowany 1x, ostatnio: remigio, 2011-07-27 21:54

Pozostało 580 znaków

2011-07-28 09:28
0

A możesz wejść na http://localhost:8080/manager przez przegladarke ?

Pozostało 580 znaków

2011-07-28 10:39
0

No właśnie coś dziwnego jest z tym tomcatem :/
Przez cmd i startup nie mogę odpalić tomcata.wówczas strona się nie wyświetla. Natomiast , gdy odpalam go przez IDE wszystko jest ok(tomcat rusza i stronę mogę odpalić).
Mój plugin wygląda teraz tak :

            <plugin>
                                <groupId>org.codehaus.mojo</groupId>
                                <artifactId>tomcat-maven-plugin</artifactId>
                                 <configuration>  
                    <server>atomcat6</server>                   
                    <a href="http://localhost:8080/">http://localhost:8080/</a>   
                                        <warFile>C:\Maven\target\Maven-0.1.war</warFile>
                                </configuration>
                        </plugin>

martwi mnie nieobecność settings.xml w folderze .m2/

edytowany 1x, ostatnio: remigio, 2011-07-28 10:42

Pozostało 580 znaków

2011-07-29 02:15
0

Witam
właśnie dzisiaj testowałem mavena 3 :D
zdarłem też jbossa7as odinstalowałem mavena 2 zainstalowałem 3
i muszę przyznać że jestem pod wrażeniem :D jeszcze nie widziałem takiej prostoty w działaniu
polecam http://lukieb.wordpress.com/2[...]3-on-ubuntu-10-04-lts-server/

Pozostało 580 znaków

2011-07-29 07:44
0

settings.xml w .m2 to globalne ustawienia dla danego usera jak ich nie ma to i tak powinno działać , nie używam tomcata z ide więc nie bardzo pomogę. Jedyne co rzuca mi się w oczy to zła ścieżka ma ona prowadzić do managera w tomcat a nie do głównej strony.

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0