java i UTF-8

0

Wiecie może jak ustawić w javie kodowanie na UTF-8?? Pisze projekt z javy z wykorzystaniem mavena i wszystkie próby zmiany kodowanie nic nie dają. Próbowałem dodać linijke w pomie

<plugin> 2 <groupid>org.apache.maven.plugins</groupid> 3 <artifactid>maven-resources-plugin</artifactid> 4 <version>2.4.2</version> 5 <configuration> 6 <encoding>UTF-8</encoding> 7 </configuration> 8</plugin>

ale nic to nie dało. Prosze o szybką odpowiedź. Wszystkie pomysły mile widziane

0

A co masz ustawione w IDE i jak zapisujesz pliki?

0

a to pomoze:

<plugin>
    <artifactId>maven-compiler-plugin</artifactId>
    <configuration>
        <source>${java.version}</source>
        <target>${java.version}</target>
        <encoding>UTF-8</encoding>
    </configuration>
</plugin>

??

0

@krzyzy, a co wersja javy ma do kodowania? Problem leży najprawdopodobniej w tym z jakim kodowaniem zapisywany jest plik. Jest ono inne niż to, które ustawiamy mavenowi.

0

oj, czepiasz sie (wersja javy nie ma znaczenia - to bylo copypaste z mojego projektu).

A co w przypadku gdy pliki zapisujesz w UTF-8 a kompilator odczytuje je w domyslnym kodowaniu windowsa (taki przypadek występuje gdy nie podasz mavenowi kodowania "maven-compiler-plugin->configuration->encoding")?

0

Nie widzę najważniejszego - czy chodzi o napis wpisany na stałe do pliku .java, czy też o plik znajdujący się w resources?

maven-resources-plugin dotyczy tylko plików w resources (przynajmniej domyślnie)

Jeżeli używasz Eclipsa to proponuję zacząć od dopisania w eclipse.ini "-Dfile.encoding=UTF-8" (koniecznie po -vmargs)
Możemy też w Eclipsa w ejść do Window->Preferences->General->Content Type->Text->Java source file i w Default encoding wpisać"UTF-8".
Od teraz każdy plik .java (jeżeli nie zmienimy na poziomie projektu) będzie zapisywany w UTF-8.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0