nie dziala program po wyrzuceniu go do ja-a

0

Witam,
mam dziwny problem, pracuje na Eclipse SDK ver. 3.2.1
gdy odpalam swoj kod spod eclipsa to sie normalnie odpala i wszystko dziala, ale jak wyrzuce program do jar-a to nie tworzy sie obiekt klasy server i program utyka.
Kod sklada sie z kilku plikow wiec tu zamieszczam skompresowany caly katalog z projektem:
http://www.simon2001.yoyo.pl/mail_forum.zip

Zamiescilem tutaj tylko ta czesc programu ktora nie dziala (caly program ma ponad 1k linijek ale wszystko inne dziala, tzn obiekty innych klas sie tworza i dzialaja ich wszystkie funkcje.

Komplilator ni wykrywa bledu w skladni kodu, problem raczej nie tkwi tez z wyrzucaniem do jar-a bo wszystko inne (nawet po wyrzuceni do jar-a) dziala poprawnie.

Prosze pilnie o pomoc bo mam ten projekt w poniedzialek oddac na zaliczenie :(
w razie czego moj kontakt [email protected]

0

no coz, mozna to zrobic przez eksport (eclipse):

  • najezdzasz na projekt i dajsze export
  • wybierasz miejsce gdzie ma byc plik jar i co ma byc po kompilacji
  • dalej (zaznaczasz ze moze exportowac z bledami
  • kolejna opcja jest wybor projektu zeby kompilator wiedzial co ma byc w tym naszym jar'e (2 i 3 od konca opcja)
  • ostatnia wybor klasy main projektu
    jak tak zrobisz to na pewno zadziala no chyba ze masz jakies dolaczone zewnetrzne biblioteki w jar'e (nie wiem jak to sealowac do projektu )
    jak zrobisz wg. tych wskazowek to powino smigac

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0