Excel - naprzemienne wypełnianie komórek różnymi wartościami

0

1100.0
1102.4
1122.0
1124.4
1144.0
1146.4

Jak coś takie wykonać, chce aby druga komórka była większa o 2.4 od poprzedniej, trzecia o 21.6 od poprzedniej, czwarta o 2.4 od poprzedniej, itd.
Jak coś takiego wykonać ? Wystarczy jakaś formuła ?

0

W komórce d2 = 1100
W komórce D3 wpisujesz:
=JEŻELI(MOD(WIERSZ();2);D2+2,4;D2+21,6)
i kopiujesz tą formułę w dół.

0

Pluje się że WIERSZ() jest puste :(

Co tam trzeba wpisać ?

0

Sprawdzałem w Excel 2007 i OpenCalc 4.0 - działa bez parametru

0

Sprawdź taki zapis:
=JEŻELI(MOD(WIERSZ( D3 );2);D2+2,4;D2+21,6)

0

Czerwoną strzałką zaznaczyłem bład który dostaję ... kiedy WIERSZ() jest puste.
A niebieską, po wpisaniu J7 i przeciągnięciu w dół, wypełnia komórki tylko co 2,4.

0

Musisz potestować funkcję REST() czy zwraca naprzemiennie wartości 0 i 1.
Tak działa funkcja MOD().

1

tutaj masz link do arkusza google.
Pobierz go sobie na kompa i sprawdź, czy będzie działać.

0

Działa Super !
Jak przepisuje do siebie tą formułę to u mnie działa tak jak powinna, ale jak kopiuje to jest ok - trochę dziwne .. może popełniam mały błąd przy przepisywaniu.

Aby uzyskać zamierzony efekt, potrzebuje jeszcze w miejsce po kropce wstawić 0.
Jak to zrobić ?

1

=IF(RIGHT(H3;1)=".";H3&0;H3)
Rzuć okiem do arkusza google, który wcześniej udostępniłem.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0