problem z autorun.inf

0

Witam. Mam problem z plikiem autorun.inf, a konkretnie z widocznością zasobów otwieranej aplikacji. Chodzi mi o to, że jak w pliku autorun otwieram program, który ma otworzyć bitmapę i ją wyświetlić na formie to dostaję samą formę i komunikat o błędzie z poziomu programu, że nie może odnaleźć składowego pliku. Ca mam zrobić by plik autorun najpierw wchodził do katalogu z zasobami a następnie odpalał główny plik? dla lepszego wyjaśnienia problemu dodam kod aplikacji, która ma się uruchamiać bez pośrednio po umieszczeniu płyty w napędzie

using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;

namespace obrazek
{
    public partial class Form1 : Form
    {
        Bitmap bmp;
        public Form1()
        {
            InitializeComponent();
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            try
            {
                bmp = new Bitmap("obraz.bmp");
                pictureBox1.Image = bmp;
            }
            catch (Exception x)
            {
                MessageBox.Show("Wystąpił błąd " + x.Message.ToString());
            }
        }

        private void pictureBox1_Click(object sender, EventArgs e)
        {

        }
    }
}

odpowiednią bitmapę wrzuciłem do katalogu Debug. Następnie za folderem debug utworzyłem plik autorun.inf o następującej zawartości


[autorun]
open=Debug/obrazek.exe
icon=ikona.ico

Struktura obrazu dysku wygląda tak
user image
Tak powinien wyglądać program po jego otwarciu
http://www.fotosik.pl/pokaz_obrazek/pelny/8162c9e0060332ed.html
a tak wygląda po otwarciu przez plik autorun.inf
http://www.fotosik.pl/pokaz_obrazek/022b1997a65b1108.html

0

Zamiast tworzyć dziwne obejścia zrób to porządnie, czyli albo dodaj grafikę do zasobów aplikacji, albo w konstruktorze Bitmap podaj ścieżkę do Application.StartupPath + @"\obraz.bmp".

0

somekind wielkie dzięki. użycie Application.startUpPatch rozwiązało problem. Teraz nie tylko wyświetla się obrazek po uruchomieniu wirtualnego dysku, ale rónież mogę tworzyć startowe programy, za pomocą których wybieram aplikację umieszczoną na płycie :D

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0