Linux - jak usunac gtk? (nie mam juz zrodel)

0

Witam,

Problem jest taki, ze przy probie kompilacji kazdego programu dostaje taki blad:

  • 'pkg-config --modversion gtk+-2.0' returned 2.6.9, but GTK+ (2.6.4)
    • was found! If pkg-config was correct, then it is best
    • to remove the old version of GTK+. You may also be able to fix the error
    • by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    • /etc/ld.so.conf. Make sure you have run ldconfig if that is
    • required on your system.
    • If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    • to point to the correct configuration files

Pytanie, co teraz zrobic? Usunac gtk 2.6.9? Nie wiem jak, nie moge zrobic make uninstall, bo nie mam zrodel, z ktorych to bylo kompilowane.

Jak to rozwiazac?

0

Nie napisales nawet jakiej dystrybucji uzywasz ani co zrobiles ze tak sie stalo. Na pierwsz rzut oka wyglada ze spaprales system pakietow instalujac ze zrodel biblioteke ktora miales juz zaintalowana z pakietow dystrybucyjnych. Kasujac zrodla w zasadzie uniemozliwiasz sobie sensonwe odinstalowanie czegos co z nich instaluejsz. Moja rada jest taka, zainstaluj system jeszcze raz i w przyszlosci uzywaj pakietow dystrybucyjnych, a jak juz musisz cos ze zrodel to zawsze je trzymaj zeby pozniej moc to odinstalowac.

0

ewentualnie uzywaj takich programow jak checkinstall kotre robia paczke dla twojego systemu, z ktorej bedziesz mogl instalowac dany program i potem latwo go usuwac

0

No nie przerazajcie mnie, naprawde nie da sie nic z tym zrobic? Ponownie instalowanie systemu raczej odpada

Chyba wlasnie instalowalem GTK ze zrodel, ale to dlatego, ze nie bylo pakietow w wystarczajaco nowej wersji..

Moze jest jakis sposob, zeby sprawdzic, jakie pliki trzeba usunac aby odinstalowac jedna wersje GTK? Bo chyba o to chodzi, ze jest zainstalowane to podwojnie... :/

Linux Knoppix 4.02, kernel 2.6.12

0
othello napisał(a)

No nie przerazajcie mnie, naprawde nie da sie nic z tym zrobic? Ponownie instalowanie systemu raczej odpada

Chyba wlasnie instalowalem GTK ze zrodel, ale to dlatego, ze nie bylo pakietow w wystarczajaco nowej wersji..

Moze jest jakis sposob, zeby sprawdzic, jakie pliki trzeba usunac aby odinstalowac jedna wersje GTK? Bo chyba o to chodzi, ze jest zainstalowane to podwojnie... :/

Linux Knoppix 4.02, kernel 2.6.12

Mozesz sprobowac sciagnac to swoje gtk 2.6.9 zaintalowac ze zrodel jszcze raz, i odinstalowc. Generlanie to instalowanie takich bibliotek jak gtk ze zrodel to dobry sposob spaprac sobie system. Jak twoja dystrybucja nie ma wystarczajaco nowych pakietow to zmien ja na taka ktora je ma.

0

No do Knoppixa instaluje sie pakiety debiana. Najnowsza obecnie dostepna wersja GTK to wlasnie 2.6.4 - pomimo ze chyba juz GTK 2.12 jest, ale tylko jako zrodla.

0
othello napisał(a)

No do Knoppixa instaluje sie pakiety debiana. Najnowsza obecnie dostepna wersja GTK to wlasnie 2.6.4 - pomimo ze chyba juz GTK 2.12 jest, ale tylko jako zrodla.

Knoppix uzywa systemu pakietow debiana, z czy pakietow debiana to bym sie sprzeczal(ale glowy niedam). Co do najnowszej wersji to sa w debianie galezie testing i unstable. Tak na marginesie to jest jakiskonketny powod dla ktorego chcesz miec najnowsza wersje gtk poza tym ze jest nowsza? Myslisz ze ci to cokokolwiek zmieni? :)

0

To nie o to chodzi. Kiedys instalowalem najnowsza wersje, ze zrodel bo jakis program wymagal takiej wersji, a w pakietach nie bylo.

Wiec, na dzien dzisiejszy mam ta nowsza instalowana kiedys ze zrodel i ta starsza - instalowana z pakietu deb.

No i teraz jestem w kropce: bo GTK jest, ale sa dwie wersje i zawsze mam taki blad. Mysle nawet, zeby zmodyfikowac skryp configure programu tak zeby nie sprawdzal ktore gtk jest zainstalowane, moze to przejdzie i skompiluje mi sie ten program? :| Ale pewnie bede jakies bledy kompilacji jak bedzie probowal uzyc nie tego GTK co trzeba...

0

a

You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.

?

//@edit przy instalacji raczej nie trzeba sie pozbywac starej wersji - nowa ja nadpisuje (chyba ze sie babrzesz w konfiguracji i podajesz inne sciezki)

0
lofix napisał(a)

@edit przy instalacji raczej nie trzeba sie pozbywac starej wersji - nowa ja nadpisuje (chyba ze sie babrzesz w konfiguracji i podajesz inne sciezki)

Jak instalujesz cos ze zrodel do to to nie nadpisze tego co bylo instalowane z pakietow bo to domyslnie idzie do /usr/local/. A tamten kolega niech lepiej nie tyka zmeinnych systemowych ani plikow konfirguracyjnych bo predzej jeszcze bardziej cos spaprze niz naprawi ;-).

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0