[Kylix] Problem z uruchomieniem aplikacji

0

Zainstalowalem sobie ostatnio Mandrive 2006 i pod nia Kylixa 3 Open Edition.

Problem pojawia sie podczas uruchomienia napisanej aplikacji...
Przy probie jej uruchomienia Kylix sie zawiesza...

Czytalem ze najmniej problemu z Kylixem jest pod RedHatem oraz Mandrakiem.

Ma ktos moze Mandrive i podobne problemy? Moze przynajmniej podobne doswiadczenia?

Prosze o pomoc, mi juz rece opadaja... brak pomyslow.
ps: chcialbym pozostac przy obecnej dystrybucji linuxa.

0

chciałem zauwazyc ze Kylix jest bardzo stary, mozna rzec archaiczny do systemu którego używasz i prawdopodobnie jakies biblioteki sie nie zgadzaja.

0

Spin: bez przesady. Kylix 3 jest odpowiednikiem Delphi 6, który bądź co bądź wciąż cieszy się dużą popularnością. Osobiście od zawsze używam systemów z rodziny RedHata (RedHaty jako takie, Aurox, ostatnio Fedora Core), więc niestety nie jestem w stanie określić, co może być nie tak. Mi Kylix 3 ładnie chodził. Mogę jedynie zaproponować wypróbowanie jednej rzeczy: skompilowanie jakiegoś programu i uruchomienie go spoza środowiska Kylixa (normalnie z shella). Może pomoże. Jeśli to zadziała, to sprowadzi główną część podejrzeń na sam debugger, który faktycznie może mieć kłopoty w działaniu pod inną dystrybucją.

0

Faktycznie zapomnialem napisac ze skompilowany program uruchomiony z shella dziala poprawnie. Kylix jedynie lapie zawieche podczas proby uruchomienia aplikacji. Kompilowac, kompiluje sie wszystko ladnie.

Na upartego moglbym pracowac uruchamiajac skompilowane programy z shella jednak jest to spore utrudnienie poniewac F9 wciskam instynktownie gdy chcĘ sprawdzic czy wszystko dziala...

Jaka zatem dystrybucje polecacie? Najlepiej jakas do ktorej nie trzeba doisntalowywac dodatkowych bibliotek.

Moze jeszcze jednak zaczekam az wypowie sie ktos komu Kylix dziala poprawnie pod Mandriva...

aha uzuwam srodowiska graficznego KDE.
Nie sadze aby to byla wina KDE ale moze sprobowac z Gnomem?

Jakiego wy uzywacie?

0

srodowisko nie ma znaczenia. raczej wersja glibc

0

A jak ty go z konsol odpalasz bo ja mma taki sam problem
daję:

/home/konrad/projekty/Project2

/home/konrad/projekty/Project2: symbol lookup error: /home/konrad/projekty/Project2: undefined symbol: initPAnsiStrings
[[email protected] ~]$

1 użytkowników online, w tym zalogowanych: 0, gości: 1