Ciąg dalszy sieci...

0

Zamieszczam w poście Pełny Plik INF, do którego w2k, się czepia, bo nie może znaleźć odpowiedzniego wiersza.
Kto mi pomoże znalexć błąd do tej karty sieciowej? Lub Kartę RL2000 Fast Ethernet

;****
;
; RlWINND3.INF for Compex RL2000 10Base-T PCI Ethernet Network Card
;
; Copyright(C) PowerMatic Data System Ltd. 1998-2001
;
; NDIS3 for Windows 98 and Windows 2000
;
;****

[Version]
Signature = "$Chicago$"
Class = Net
ClassGUID = {4d36e972-e325-11ce-bfc1-08002be10318}
Provider = %Msft%
LayoutFile = layout.inf
Compatible = 1

[Manufacturer]
%V_PDS% = COMPEX

[ControlFlags]
ExcludeFromSelect = PCI\VEN_11F6&DEV_1401
;;PCI\VEN_11F6&DEV_2011&SUBSYS_201111F6

[COMPEX]
%Rl2000.DeviceDesc% = Rl2000.ndi,PCI\VEN_11F6&DEV_1401

;================================================================================================
;
; Win9x specific sections
;
;================================================================================================
[Rl2000.ndi]
AddReg = rl2000.id.reg, rl2000.win.reg
DeviceID = "PCI\VEN_11F6&DEV_1401"
LogConfig = DefaultConfig

;==========================================================================================
;
; WinNT 5.0 specific sections
;
;================================================================================================
[Rl100atx.ndi.NT]
AddReg = rl2000.reg
BusType = 5
Characteristics = 0x84
CopyFiles = rl2000.CopyFiles

[Rl100atx.ndi.NT.Services]
AddService = RL2000, 2, rl100atx.Service, common.EventLog

;------------------------------------------------------------------------------------------
; Win9x id registry sections These are not needed by NT
;------------------------------------------------------------------------------------------
[rl2000.id.reg]
HKR,Ndi,DeviceID,,"PCI\VEN_11F6&DEV_1401"

[rl2000.win.reg]
; key,subkey,valuname,type,value
HKRDevLoader*ndis
HKRDeviceVxDsRl2000.sys
HKREnumPropPages"netdi.dll,EnumPropPages"

; NDIS Info
HKR,NDIS,LogDriverName,,"Rl2000"
HKR,NDIS,MajorNdisVersion,1,03
HKR,NDIS,MinorNdisVersion,1,0A

; Interfaces
HKR,Ndi\Interfaces,DefUpper,,"ndis3"
HKR,Ndi\Interfaces,DefLower,,"ethernet"
HKR,Ndi\Interfaces,UpperRange,,"ndis3"
HKR,Ndi\Interfaces,LowerRange,,"ethernet"

; Install sectioins
HKR,Ndi\Install,ndis3,,"rl2000.ndis3"

[rl2000.ndis3]
CopyFiles = rl2000.ndis3.CopyFiles

[rl2000.ndis3.CopyFiles]
Rl2000.sys,,,2

[rl2000.inf.CopyFiles]
Rl2000.inf,,,2

;------------------------------------------------------------------------------------------------
; Rl100atx NT specific
;------------------------------------------------------------------------------------------------
[rl2000.reg]
HKR, Ndi\Interfaces, DefUpper, 0, "ndis5"
HKR, Ndi\Interfaces, DefLower, 0, "ethernet"
HKR, Ndi\Interfaces, UpperRange, 0, "ndis5"
HKR, Ndi\Interfaces, LowerRange, 0, "ethernet"
HKR, Ndi, Service, 0, "RL2000"

[rl2000.Service]
DisplayName = %Rl2000.Service.DispName%
ServiceType = 1 ;%SERVICE_KERNEL_DRIVER%
StartType = 3 ;%SERVICE_DEMAND_START%
ErrorControl = 1 ;%SERVICE_ERROR_NORMAL%
ServiceBinary = %12%\Rl2000.sys
LoadOrderGroup = NDIS

[common.EventLog]
AddReg = common.AddEventLog.reg

[common.AddEventLog.reg]
HKR, , EventMessageFile, 0x00020000, "%%SystemRoot%%\System32\netevent.dll"
HKR, , TypesSupported, 0x00010001, 7

[rl2000.CopyFiles]
Rl2000.sys,,,2

;================================================================================================
;
; Common sections for Win9x and Win NT 5.0
;
;================================================================================================
[DestinationDirs]
rl2000.ndis3.CopyFiles = 11
rl2000.inf.CopyFiles = 17
rl2000.CopyFiles = 12

;================================================================================================
;
; Localizable Strings
;
;================================================================================================
[strings]
Msft = "Compex"
V_PDS = "Compex"

Rl2000.DeviceDesc = "Compex RL2000 PCI Fast Ethernet Adapter"
Rl2000.Service.DispName = "Compex RL2000 PCI Fast Ethernet NDIS3 Driver"

No i co z tym fantem zrobić, przez to coś ni emoge mieć sieci 100Mbit.

0

A we wlasciwosciach seiciowki nie masz pola wyboru predkosci?
typu HalfDuplex,FullDuplex,automatycznie czy jakos podobnie.. ?

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0