Perypetie z Kubuntu 18.04. Nie działa "mouse click emulation"

Odpowiedz Nowy wątek
2019-02-26 20:38
0

Po 2 latach ponownie dałem szansę linuxowi. Wybór padł na Kubuntu 18.04. System fajny lecz przerażony jestem masą bugów na moim dell xps. Zmieniłem laptopa (na nowszego della xps), zainstalowałem ponownie ten sam system i niektóre błędy zniknęły, ale pojawiły się kolejne. Jestem przerażony ilością baboli jakie sprawiają że ciężko się z tym systemem pracuje.

Dziś po odłączeniu kabla Ethernet, system nie widział żadnej sieci Wifi :| Pomógł restart komputera.

Kolejna rzecz: po restarcie nie działa "mouse click emulation". Co najlepsze działa gdy wyloguje się z systemu i zaloguje ponownie :D Działa do czasu kolejnego restartu. Ale po kolei: otwieram ustawienia touchpada:

screenshot-20190226203213.png

Jak widać okno jest zbyt małe w stosunku do tego co się w nim znajduje. Ale to nic. Rozszerzam sobie to okienko aby widzieć wszystkie dostępne opcje. To nic że większość opcji jest nieaktywna (nie wiedzieć czemu). Minimalizuje okno i przywracam ponownie. Ponownie zmienia się jego rozmiar na ten domyślny. Ponownie okno jest zbyt małe ;) Kolejny babol. Niemniej jednak widać że ustawienia są włączone lecz jednokrotne dotknięcie palcem touchpada nie symuluje kliknięcia myszy.

Kolejna rzecz: instaluje narzędzia JetBrainsa. Po zminimalizowaniu okna IDE, nie można go potem przywrócić ;) Okno się przywraca ale nie na pierwszy plan (jest gdzieś schowane za innymi oknami).

Takich dziwnych rzeczy jest więcej. Chyba zacznę prowadzić wpisy na mikroblogu opisujące dziwactwa linuxa. Niemniej jednak jeżeli ktoś zna rozwiązanie któregoś z moich problemów to będę baaardzo wdzięczny.

Mnie się trochę wydało, że opisujesz issues, które każdy z nas mógłby założyć w odpowiednich projektach na GitHubie. :D Mnie też denerwują pewne błędy w Linuksie. - Silv 2019-02-26 22:21

Pozostało 580 znaków

2019-02-26 20:55
1

A czemu kubuntu? Tak Ci zależy na KDE?

Ja osobiście kiedy tylko mogę, staram się unikać Ubuntu w jakiejkolwiek postaci. Na serwer dawniej dawałem Slackware, ale że ta dystrybucja jest w stanie agonalnym, to teraz Debian. A na desktop to tylko i wyłącznie Mint. Sam używam wersji Mate, bo mi jej prostota i brak wodotryskow jak najbardziej pasuje, ale w sumie jakakolwiek wersja będzie lepsza niż Ubuntu :p

Kilka osób z forum nawróciłem na minta i z tego co kojarzę to przy nim zostali. Czasem trochę ponarzekaja że coś nie do końca działa, ale i tak z dostępnych Linuksów na desktop to jest IMHO najlepsza opcja.


That game of life is hard to play
I'm gonna lose it anyway
The losing card I'll someday lay
So this is all I have to say

Pozostało 580 znaków

2019-02-26 21:14
xy
0

Co do Wi-Fi, to laptopy Dell XPS 13 Developer Edition, czyli standardowo z Ubuntu, przynajmniej kiedyś miały inny układ do Wi-Fi (chyba Intela), bo ten inny w zwykłych XPS 13 nie lubił się do końca z Linuksem. Dell XPS 15 nie ma wersji standardowo z Ubuntu, ale bliźniaczy Precision ma i jest ta sama sytuacja z układami do Wi-Fi. Może to jest właśnie to. Nawet czytałem gdzieś piękne opowieści, że przy gwarancji NBD przyjeżdzał spec i wymieniał układ Wi-Fi na ten pod Linuksa. :)

Pozostało 580 znaków

2019-02-26 22:29
1
Adam Boduch napisał(a):

Dziś po odłączeniu kabla Ethernet, system nie widział żadnej sieci Wifi :| Pomógł restart komputera.

Próbowałeś samego wylogowania?

Adam Boduch napisał(a):

po restarcie nie działa "mouse click emulation".

Może kwestia sterowników touchpada. Po doświadczeniach z Linuksem mogę nawet zakładać, że nie dla wszystkich touchpadów są (odpowiednie) sterowniki.

Adam Boduch napisał(a):

instaluje narzędzia JetBrainsa. Po zminimalizowaniu okna IDE, nie można go potem przywrócić

Nie znam rozwiązania, ale jeśli pozwolisz, skojarzyła mi się z tym moja własna lekcja co do Linuksa: nie naciskać niepotrzebne żadnych kombinacji klawiszy. Potem się okazuje, że ustawienia, które zostały przypadkowo zmienione, są gdzieś bardzo głęboko (dlatego właśnie jest skrót).

Adam Boduch napisał(a):

Chyba zacznę prowadzić wpisy na mikroblogu opisujące dziwactwa linuxa.

Ja popieram!


UPDATE:

Zainstalowałem sobie właśnie KDE Plasma 5.14 na Fedorze 29 i tak:

  1. Wi-Fi nie sprawdzałem.
  2. Mouse click emulation u mnie działa. Co prawda prawy i środkowy przycisk (odpowiednio dwa i trzy palce) działają kiedy chcą, ale domyślam się, że to kwestia jakichś parametrów związanych z szybkością i długością klikania (może nawet do zmiany?).
  3. U mnie okno ustawień touchpada też jest mniejsze niż treść, widać taki mechanizm przyjęto. Trzeba mu oddać sprawiedliwość, że jest elastyczny (ile by nie było przycisków w okienku, i tak się wyświetlą wszystkie).
  4. Większość opcji tak jak u Ciebie jest nieaktywna, to rzecz do zastanowienia.
  5. Po zmianie rozmiaru, minimalizacji i przywróceniu, okno tak jak u Ciebie zmienia rozmiar na domyślny. Ciekawe.
  6. JetBrains instalować nie będę – a u mnie jak na razie wszystkie sprawdzone okna można przywracać na pierwszy plan.

PS. Zauważyłem, są na dole w ustawieniach touchpada ustawienia szybkości kliknięcia (poza trzema palcami), ale nieaktywne.


UPDATE:

Ad. 4. Gwoli ścisłości, w dokumentacji KDE ustawień touchpada znalazłem:

In this section you can manage the settings for your mouse trackpad. Settings may vary based on hardware and drivers installed.

Gdybym znał się na sterownikach, to zaryzykowałbym tezę, że Twój aktualny nie obsługuje zmiany tych domyślnych ustawień, które są niedostępne. PS. Poszukaj w repozytorium Kubuntu, może są jakieś dodatkowe sterowniki.


UPDATE:

Jeżeli Twój touchpad to Synaptics, oraz Kubuntu używa X.org, oraz Kubuntu używa tych samych sterowników do touchpada co Ubuntu (zakładam wszystkie trzy warunki, nie sprawdzałem), to tutaj – https://packages.ubuntu.com/s[...];suite=cosmic&section=all – masz dostępne sterowniki z repozytorium Ubuntu. Nie jestem też przekonany, jak to jest z wersjami Ubuntu, nie znam go.

edytowany 16x, ostatnio: Silv, 2019-02-27 00:55

Pozostało 580 znaków

2019-02-28 06:46
0

@cerrato: miałem kiedyś minta. Jednak interfejs kubuntu znacznie bardziej mi pasuje. No i jest więcej opcji konfiguracji.

@xy: może coś w tym jest. W pracy czasami mi wifi nie działa. Tzn. nie zrywa połączenia z siecią ale internet ucina. W domu natomiast jest ok. Hmmm...

@Silv: niestety nie mogę zainstalować tych sterowników: xserver-xorg-input-synaptics : Depends: xserver-xorg-core (>= 2:1.18.99.901)

Pozostało 580 znaków

2019-02-28 14:50
0

Co do sterowników: jaką masz w tej chwili wersję xserver-xorg-core? Czy w ogóle masz zainstalowany ten pakiet? Jakie pakiety są dostępne w Kubuntu o tej nazwie? (ja nie mam możliwości przetestowania Kubuntu)

Pozostało 580 znaków

2019-02-28 18:15
0
xserver-common/bionic-updates,bionic-updates,bionic-security,bionic-security,now 2:1.19.6-1ubuntu4.2 all [installed]
xserver-xorg-core-hwe-18.04/bionic-updates,now 2:1.20.1-3ubuntu2.1~18.04.1 amd64 [installed]
xserver-xorg-hwe-18.04/bionic-updates,now 1:7.7+19ubuntu8~18.04.2 amd64 [installed]
xserver-xorg-input-all-hwe-18.04/bionic-updates,now 1:7.7+19ubuntu8~18.04.2 amd64 [installed]
xserver-xorg-input-libinput-hwe-18.04/bionic-updates,now 0.28.1-1~18.04.1 amd64 [installed]
xserver-xorg-input-wacom-hwe-18.04/bionic-updates,now 1:0.36.1-0ubuntu1~18.04.1 amd64 [installed]
xserver-xorg-legacy-hwe-18.04/bionic-updates,now 2:1.20.1-3ubuntu2.1~18.04.1 amd64 [installed]
xserver-xorg-video-all-hwe-18.04/bionic-updates,now 1:7.7+19ubuntu8~18.04.2 amd64 [installed]
xserver-xorg-video-amdgpu-hwe-18.04/bionic-updates,now 18.1.0-1~18.04.1 amd64 [installed]
xserver-xorg-video-ati-hwe-18.04/bionic-updates,now 1:18.1.0-1~18.04.1 amd64 [installed]
xserver-xorg-video-fbdev-hwe-18.04/bionic-updates,now 1:0.5.0-1ubuntu1~18.04.1 amd64 [installed]
xserver-xorg-video-intel-hwe-18.04/bionic-updates,now 2:2.99.917+git20171229-1ubuntu1~18.04.1 amd64 [installed]
xserver-xorg-video-nouveau-hwe-18.04/bionic-updates,now 1:1.0.15-3~18.04.1 amd64 [installed]
xserver-xorg-video-qxl-hwe-18.04/bionic-updates,now 0.1.5-2build2~18.04.1 amd64 [installed]
xserver-xorg-video-radeon-hwe-18.04/bionic-updates,now 1:18.1.0-1~18.04.1 amd64 [installed]
xserver-xorg-video-vesa-hwe-18.04/bionic-updates,now 1:2.4.0-1~18.04.1 amd64 [installed]
xserver-xorg-video-vmware-hwe-18.04/bionic-updates,now 1:13.3.0-2build1~18.04.1 amd64 [installed]

Kolejny przykład WTF Ubuntu. Czy wiedzieliście, że jeżeli w tym oknie wybiorę jakąś pozycję z listy Profile to działanie przycisków Ok, Apply i Cancel jest takie samo? :D Po prostu zapisywana jest wybrana wartość.

screenshot-20190228181554.png

Rzeczywiście co do przycisków, mogłbym mieć wątpliwości, czemu ich aż tyle. Według moich doświadczeń z kilkoma graficznymi interfejsami w Fedorze, samo zamknięcie okna (choćby klawiszem ESC) często powoduje zapis wartości (może w przypadku tych mniej ważnych ustawień). - Silv 2019-02-28 18:21
Dokładnie też mam takie wrażenie, tzn. że zamknięcie okna zapisuje wartość więc przyciski są tu niepotrzebne. Nawet przycisk Defaults nie działa, tzn. nie przywraca domyślnych wartości ;) Nie wiem co on robi :P - Adam Boduch 2019-02-28 18:22
Być może ten interfejs miał być dostosowany do jakiejś innej dystrybucji niż Kubuntu, a w Kubuntu po prostu niektóre jego funkcje są z automatu niedostępne? Kto wie. - Silv 2019-02-28 18:24

Pozostało 580 znaków

2019-02-28 19:08
0

Zobacz ten wątek: https://askubuntu.com/questio[...]nstalling-libinput-on-16-04-2 (przeczytaj też komentarze – this can break the graphic environment and you'll have to boot in command line mode to revert this step, ale nie wiem, do czego to miałoby się odnosić; w sumie jeśli nawet tak, to nie byłoby to zbyt duże ryzyko, przynajmniej dla mnie, bo domniemywam, że z linii komend jest bardzo prosto to zrobić). Zgodnie z wątkiem, spróbuj zainstalować wersję z fragmentem hwe, bo widzę, że tę drugą próbowałeś instalować.


PS. Dla ciekawości, ten przyrostek hwe to zdaje się być to (ale sprawdź dokładnie, żeby być pewnym): https://wiki.ubuntu.com/Kernel/LTSEnablementStack

edytowany 8x, ostatnio: Silv, 2019-02-28 23:02

Pozostało 580 znaków

2019-02-28 19:37
0

Tak zrobiłem i pozbawiłem sie grafiki :D Dzięki za pomoc, ale chyba będę musiał nauczyć się z tym żyć :( Boje się już cokolwiek dotykać na linuxach, bo łatwo popsuć.

Pozostało 580 znaków

2019-02-28 19:40
0

Ale przez moją radę? To przepraszam. :( Ale już masz grafikę? Ciekawa sprawa. Jeśli będę mieć możliwość, to zobaczę to Kubuntu. A Ty, jeśli możesz i by Ci się chciało, możesz sobie na maszynie wirtualnej postawić Fedorę – nawet z KDE Plasmą, a co – i wtedy będę mieć łatwiej z debugowaniem. :)


PS. Głupio powiedziałem, nie będę mieć po co patrzeć, bo przecież mam inny touchpad. :(


PS2. Jeżeli jakiś błąd się pojawił w przypadku braku grafiki, to napisz. Może to naprowadzi nas na rozwiązanie problemu (touchpada).

edytowany 5x, ostatnio: Silv, 2019-02-28 23:03

Pozostało 580 znaków

2019-03-12 19:20
0

Kolejny problem z linuxem. Dźwięk odtwarzany przez HDMI zaczął trzeszczeć. Odłączyłem kabel hdmi aby za chwile podlaczyc. Teraz dzwięku nie ma w ogole :D W Ustawieniach glosnosci pojawia sie "dummy output" i to wszystko ;) Ręce opadaja :P

U mnie niestety działa, więc ja już nie będę proponować niesprawdzonych rozwiązań. :( Szkoda, lubię naprawiać, gdybym miał jak... - Silv 2019-03-12 22:31
Normalnie mi też działało :) Ale się popsuło. Chciałem się tylko wyżalić, już mi lepiej ;-) - Adam Boduch 2019-03-13 07:19
Mam to samo w Linux Mint. Póki co ustaliłem że to wina czegoś w Firefox (zamknięcie i otwarcie pomaga). - vpiotr 2019-03-13 08:04
@Adam Boduch: ok. Zawsze chętnie poczytam. ;) - Silv 2019-03-13 13:32

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0