apt-get nie można zainstalować/upgrade'ować paczek

Odpowiedz Nowy wątek
2017-11-06 13:00
0

Cześć
Mam dość dziwny problem z apt-get'em. Mianowicie potrzebuję zaktualizować jedną paczkę. Standardowo:

apt-get update
apt-get install --only-upgrade

Niestety zwraca mi to błędy. Postanowiłem więc spróbować zupgrejdować wszystko:

apt-get upgrade

Co również zwróciło mi następujące błędy:

Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
The following packages were automatically installed and are no longer required:
libgd3 libjbig0 libtiff5 libvpx3 libxpm4 linux-headers-4.4.0-62
linux-headers-4.4.0-62-generic linux-image-4.4.0-62-generic snap-confine
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
23 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up grub-pc (2.02~beta2-36ubuntu3.14) ...
/usr/bin/ucf: line 567: awk: command not found
dpkg: error processing package grub-pc (--configure):
subprocess installed post-installation script returned error exit status 127
Setting up openjdk-8-jre-headless:amd64 (8u131-b11-2ubuntu1.16.04.3) ...
/var/lib/dpkg/info/openjdk-8-jre-headless:amd64.postinst: 47: /var/lib/dpkg/info/openjdk-8-jre-headless:amd64.postinst: awk: not found
dpkg: error processing package openjdk-8-jre-headless:amd64 (--configure):
subprocess installed post-installation script returned error exit status 127
Setting up initramfs-tools (0.122ubuntu8.9) ...
update-initramfs: deferring update (trigger activated)
Setting up locales (2.23-0ubuntu9) ...
/var/lib/dpkg/info/locales.config: 539: /var/lib/dpkg/info/locales.config: awk: not found
dpkg: error processing package locales (--configure):
subprocess installed post-installation script returned error exit status 127
Setting up php7.0-common (7.0.22-0ubuntu0.16.04.1) ...
/usr/bin/ucf: line 567: awk: command not found
dpkg: error processing package php7.0-common (--configure):
subprocess installed post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of php7.0-json:
php7.0-json depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.

dpkg: error processing package php7.0-json (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-opcache:
php7.0-opcache depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.

dpkg: error processing package php7.0-opcache (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-readline:
php7.0-readline depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.

dpkg: error processing package php7.0-readline (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-cli:
php7.0-cli depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.
php7.0-cli depends on php7.0-json; however:
Package php7.0-json is not configured yet.
php7.0-cli depends on php7.0-opcache; however:
Package php7.0-opcache is not configured yet.
php7.0-cli depends on php7.0-readline; however:
Package php7.0-readline is not configured yet.

dpkg: error processing package php7.0-cli (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libapache2-mod-php7.0:
libapache2-mod-php7.0 depends on php7.0-cli; however:
Package php7.0-cli is not configured yet.
libapache2-mod-php7.0 depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.
libapache2-mod-php7.0 depends on php7.0-json; however:
Package php7.0-json is not configured yet.
libapache2-mod-php7.0 depends on php7.0-opcache; however:
Package php7.0-opcache is not configured yet.

dpkg: error processing package libapache2-mod-php7.0 (--configure):
dependency problems - leaving unconfigured
Setting up linux-image-4.4.0-98-generic (4.4.0-98.121) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-4.4.0-98-generic
vmlinuz(/boot/vmlinuz-4.4.0-98-generic
) points to /boot/vmlinuz-4.4.0-98-generic
(/boot/vmlinuz-4.4.0-98-generic) -- doing nothing at /var/lib/dpkg/info/linux-image-4.4.0-98-generic.postinst line 491.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-98-generic /boot/vmlinuz-4.4.0-98-generic
/etc/kernel/postinst.d/apt-auto-removal: 21: /etc/kernel/postinst.d/apt-auto-removal: awk: not found
/etc/kernel/postinst.d/apt-auto-removal: 26: /etc/kernel/postinst.d/apt-auto-removal: awk: not found
run-parts: /etc/kernel/postinst.d/apt-auto-removal exited with return code 127
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-4.4.0-98-generic.postinst line 1052.
dpkg: error processing package linux-image-4.4.0-98-generic (--configure):
subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-virtual:
linux-image-virtual depends on linux-image-4.4.0-98-generic; however:
Package linux-image-4.4.0-98-generic is not configured yet.

dpkg: error processing package linux-image-virtual (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-virtual:
linux-virtual depends on linux-image-virtual (= 4.4.0.98.103); however:
Package linux-image-virtual is not configured yet.

dpkg: error processing package linux-virtual (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-fpm:
php7.0-fpm depends on php7.0-cli; however:
Package php7.0-cli is not configured yet.
php7.0-fpm depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.
php7.0-fpm depends on php7.0-json; however:
Package php7.0-json is not configured yet.
php7.0-fpm depends on php7.0-opcache; however:
Package php7.0-opcache is not configured yet.

dpkg: error processing package php7.0-fpm (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0:
php7.0 depends on php7.0-fpm | libapache2-mod-php7.0 | php7.0-cgi; however:
Package php7.0-fpm is not configured yet.
Package libapache2-mod-php7.0 is not configured yet.
Package php7.0-cgi is not installed.
php7.0 depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.

dpkg: error processing package php7.0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-curl:
php7.0-curl depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.

dpkg: error processing package php7.0-curl (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-imap:
php7.0-imap depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.

dpkg: error processing package php7.0-imap (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-mbstring:
php7.0-mbstring depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.

dpkg: error processing package php7.0-mbstring (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-mysql:
php7.0-mysql depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.

dpkg: error processing package php7.0-mysql (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-xml:
php7.0-xml depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.

dpkg: error processing package php7.0-xml (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-zip:
php7.0-zip depends on php7.0-common (= 7.0.22-0ubuntu0.16.04.1); however:
Package php7.0-common is not configured yet.

dpkg: error processing package php7.0-zip (--configure):
dependency problems - leaving unconfigured
Setting up unattended-upgrades (0.90ubuntu0.8) ...
/usr/bin/ucf: line 567: awk: command not found
dpkg: error processing package unattended-upgrades (--configure):
subprocess installed post-installation script returned error exit status 127
Setting up grub-legacy-ec2 (0.7.9-233-ge586fe35-0ubuntu1~16.04.2) ...
Searching for GRUB installation directory ... found: /boot/grub
/usr/sbin/update-grub-legacy-ec2: line 85: awk: command not found
Cannot determine root device. Assuming /dev/hda1
This error is probably caused by an invalid /etc/fstab
/usr/sbin/update-grub-legacy-ec2: line 85: awk: command not found
/usr/sbin/update-grub-legacy-ec2: line 375: awk: command not found
dpkg: error processing package grub-legacy-ec2 (--configure):
subprocess installed post-installation script returned error exit status 127
Processing triggers for initramfs-tools (0.122ubuntu8.9) ...
/usr/sbin/update-initramfs: 222: /usr/sbin/update-initramfs: awk: not found
dpkg: error processing package initramfs-tools (--configure):
subprocess installed post-installation script returned error exit status 127
Errors were encountered while processing:
grub-pc
openjdk-8-jre-headless:amd64
locales
php7.0-common
php7.0-json
php7.0-opcache
php7.0-readline
php7.0-cli
libapache2-mod-php7.0
linux-image-4.4.0-98-generic
linux-image-virtual
linux-virtual
php7.0-fpm
php7.0
php7.0-curl
php7.0-imap
php7.0-mbstring
php7.0-mysql
php7.0-xml
php7.0-zip
unattended-upgrades
grub-legacy-ec2
initramfs-tools

edytowany 1x, ostatnio: NickOver, 2017-11-06 13:00

Pozostało 580 znaków

2017-11-06 13:36
Biały Lew
0

Spróbuj tak:
apt install awk
apt -f install

Pozostało 580 znaków

2017-11-06 13:45
0

Które wybrać?

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package awk is a virtual package provided by:
original-awk 2012-12-20-5
mawk 1.3.3-17ubuntu2
gawk 1:4.1.3+dfsg-0.1
You should explicitly select one to install.

E: Package 'awk' has no installation candidate

Pozostało 580 znaków

2017-11-06 14:09
Krzywy Programista
0

A jak wpiszesz w konsoli awk to widzi to polecenie? Jeśli nie, to raczej posypał się system i czeka cię reinstalacja. Być może posypał się dysk lub straciłeś dane z jakiegoś innego powodu.

Nie. Chce żeby je zainstalować. - NickOver 2017-11-06 14:10

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0