Dziwne zachowanie klawiatury

0

Witam mam taki problem ze swoją klawiaturą Logitech G11 przez który w zasadzie nie jestem w stanie normalnie z niej korzystać, ten tekst piszę z pomocą klawiatury programowej.
To dziwne zachowanie polega na tym, że klawisze są jakby powiązane z innymi, np. wciskam 'r' to w rzeczywistości do komputera dochodzi sygnał Alt+R (sprawdzone za pomocą narzędzia do tworzenia makr), ogólnie wygląda to tak:

  • wciskam 'p' a wychodzi mi 'p[', w drugą stronę też, czyli wciskam '[' to wyskakuje 'p['
  • 'r' -> 'alt+r' (i przez ten alt nic się nie pokazuje np. w polach tekstowych)
  • 'L' -> 'F11+L' (ciągle przy wciskaniu L włącza/wyłącza mi się pełny ekran w przeglądarce), w drugą stronę
  • 'ins' -> 'ins+home'
  • 'delete' -> 'delete+6'
    i pewnie jeszcze kilka z których rzadziej korzystam.
    Tak mam przez większość czasu, z krótkimi chwilami, kiedy klawiatura działa normalnie.
    Sprawdzałem na Windowsie jak i na Slacku dzieje się tak samo, więc chyba to nie jest raczej sprawa softu.
    Zaczęło się to niedawno kiedy zauważyłem, że czasami 'r' nie działa, teraz wydaje mi się, że się pogarsza i już w tej chwili jest prawie bezużyteczna.
    Jak myślicie jaka jest tego przyczyna?
0

Zalales moze klawiature? Wiekszosc klawiszy w srodku polaczona jest wspolna szyna, zeby nie robic jednej sciezki na klawisz tylko wykorzystac ja dla klawiszy, ktore sie nad nia znajduja. Jesli np. zalales klawiature szyna moze miec zwarcie i przy wcisnieciu jednego klawisza lapie wszystkie, ktore sa do niej przypisane, zwykle 3-4 klawisze. Ja mialem podobny do Twojego objaw w takim wlasnie przypadku. Przy czym u mnie akurat wiekszosc byla powiazana w oczywisty sposob (np. z-a-q-1 i x-s-w-2, itp.) ale niektore zupelnie w niesasiadujacy sposob. Moze u Ciebie szyna przypada na 2 klawisze?

0

mniejsza o szyny, opisane są typowe objawy zalania klawiatury.

gdy się to zdarzy podczas pracy należy natychmiast ją odłączyć, maksymalnie rozebrać i wysuszyć. kilka minut pracy „na mokro” powoduje oksydację ścieżek na folii i na czyszczenie może być już za późno.
ścieżki najlepiej czyścić spirytusem (nie wodą!) i wysuszyć. niestety, w wielu typach klawiatur nie da się za bardzo rozdzielić dwóch warstw folii bo są zgrzane ze sobą w wielu miejscach.

0

Nie przypominam sobie żebym ją kiedykolwiek zalał, zresztą dzieje się tak od ok. miesiąca-dwóch.

0

tak czy inaczej, ma zwarcie. bez jej rozkręcenia nic nie zrobisz.

0

Podłączyłem klawiaturę do laptopa i jak dotąd działa normalnie, co sugeruje, że to chyba jednak coś z moim kompem jest nie tak, może to jednak płyta główna a nie grafika?
Do kompa podłączyłem inną klawiaturę, ale na PS2 (na USB innej nie mam) i też działa normalnie.
Spróbuję jeszcze na laptopie zainstalować oprogramowanie do makr do tej klawiatury, zobaczę czy będzie dalej normalnie chodzić.
EDIT: Zresztą to nie ma sensu bo nawet na Linuksie klawisze się zacinały, spróbuję może jeszcze jakąś inną klawiaturę na USB podłączyć i zobaczyć jak będzie.

0

@AdamW,

  • klawiatura działa (bo działa podpięta do laptopa)
  • komputer jest w porządku (bo działa z inną klawiaturą)

...masz walnięty port USB.
Spróbuj na innym porcie USB (najlepiej z innej pary).

0

Komp już działa normalnie (był problem z wentylatorem na karcie graficznej), natomiast klawiatura po podłączeniu do drugiego kompa też daje takie objawy, czyli to jednak nie porty USB.
To znaczy jest tak, że jakiś czas działa normalnie a jakiś czas nie da się korzystać, póki co spróbuję jeszcze rozkręcić ją.

0
AdamW napisał(a)

natomiast klawiatura po podłączeniu do drugiego kompa też daje takie objawy, czyli to jednak nie porty USB.
To znaczy jest tak, że jakiś czas działa normalnie a jakiś czas nie da się korzystać, póki co spróbuję jeszcze rozkręcić ją.

Gdzieś w okolicach klawiszy się coś uszkodziło i klawiatura niepoprawnie wyznacza pozycję wciśniętego klawisza. Wątpię żeby ci się udało - po prostu kup nową klawiaturę.

0

Rozkręciłem ją, i zauważyłem, że na jednej z takich jakby taśm na której są normalnie białe ścieżki, w pewnym miejscu są brązowe, jakby ktoś tą taśmę przypalił (mogę wrzucić zdjęcie).
Czyli prawdopodobnie kiedyś coś nieświadomie trochę rozlałem, ścieżki się z czasem zepsuły i niepoprawnie przewodzą sygnały?

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0