Can't find unit system

Odpowiedz Nowy wątek
2006-11-03 19:44
Niewiedza
0

Zarzucam screena ale pewnie juz to widzieliscie:
http://img179.imageshack.us/my.php?image=uo0003am4.jpg

Ehh jestem nieoswiecony w tych sprawach ... niedawno zaczalem pracowac z pascalem (i w ogóle z tymi tematami). Nie wiem dlaczego pojawia sie ten komunikat... Ten sam program na innym komputerze dzialal poprawnie i wszystko bylo pieknie a tutaj przy kazdej probie stworzenia czegos nawet najprostszego wyskakuje ten blad
Can't find unit System
Byl bym bardzo wdzieczny za jakiekolwiek pomoce, wskazowki...
Pozdrawiam i prosze o zrozumienie ;.

Pozostało 580 znaków

2006-11-03 20:11
0

a moze dodaj do uses SysUtils; Moze pomoze


Tomasz Andrzejewski
Delphi (XE3-XE7) framework engineer @ InterLan
MCP: Microsoft SQL Server 2008, Implementation and Maintenance

Pozostało 580 znaków

2006-11-03 20:31
0

Może wrzucenie paczek system'u (ode mnie -> http://muchomorek.mixol.org/ftp/system.zip) do katalogu FPC -> units -> jakiś folder co tam masz ;) -> RTL (nie mam pewności czy to będzie działać bo ja mam FPC 2.0.2)

Pozostało 580 znaków

2006-11-03 23:19
0

Hmm... a przypadkiem system.tpu nie jest wbudowany w Pascala?
Mi się wydaję, że brakuje raczej jakiegoś pliku turbo.*... Bodajże turbo.tpl, ale głowy nie dam...

Pozostało 580 znaków

2006-11-04 08:37
Niewiedza
0

Sprobowalem dodac "uses sysutils" - nic
A te pliki ktore mialy zostac gdzies wrzucone - juz byly

Jakieś inne rady ?

Pozostało 580 znaków

2006-11-05 11:50
Niewiedza
0

Odswiezam ten temat poniewaz moj problem nie zostal rozwiazany...
Jest to bardzo wazne dla mnie, nigdzie nie moge znalezc odpowiedzi na zaistniala sytuacje.
Jezeli macie jakiekolwiek, nawet najglupsze propozycje na temat tego wypowiadajcie sie.
dziekuje jeszcze raz :(

Pozostało 580 znaków

2006-11-05 12:16
0

Proponuje Ci ściągnąć Delphi Personal (jest za friko, trzeba tylko kod) i napisać to tam. Tylko wtedy musisz do katalogu Lib przekopiować crt.pas. Prosiłeś o jakikolwiek pomysł i oto jest. W delphi też można pisać aplikacje konsolowe. [soczek]


Pozostało 580 znaków

2006-11-05 13:01
0

Wydaje się, że masz niepoprawne pliki lub wersje FreePascala, ale skoro błędem jest to, że w ogóle nie znajduje tego modułu, nawet gdy ręcznie skopiowałeś go tam, to może sprawdź w IDE Options ->Directories, czy wszystko jest tak jak trzeba.

Pozostało 580 znaków

2006-11-05 19:18
Niewiedza
0

No sprawdziłem w opcjach "Directories" i zamiast litery "Ł' było coś w tym stylu | wiec zmieniłem i... coś nowego ale nie wiem czy to odbrze czy źle bo problem dalej nie rozwiązany
http://img515.imageshack.us/my.php?image=uo0004lz1.jpg
No właśnie "Can't find unit cer".....
to jeszcze tak troche z opcji powrzucam moze ktos zauwazy jakies wadliwe ustawienia...
No więc zaczynam

Mode:
http://img238.imageshack.us/my.php?image=uo0005wb3.jpg
Compiler:
http://img238.imageshack.us/my.php?image=uo0007ku2.jpg
http://img518.imageshack.us/my.php?image=uo0008zw2.jpg
http://img238.imageshack.us/my.php?image=uo0009vs9.jpg
http://img509.imageshack.us/my.php?image=uo0010jh7.jpg
http://img238.imageshack.us/my.php?image=uo0011cb6.jpg
http://img238.imageshack.us/my.php?image=uo0012xg6.jpg
Memory Sizes:
http://img293.imageshack.us/my.php?image=uo0013ih6.jpg
Linker:
http://img293.imageshack.us/my.php?image=uo0014uf0.jpg
Debugger:
http://img509.imageshack.us/my.php?image=uo0015rl6.jpg
Directories:
http://img102.imageshack.us/my.php?image=uo0016nq3.jpg
http://img293.imageshack.us/my.php?image=uo0017lh0.jpg
http://img293.imageshack.us/my.php?image=uo0018vh6.jpg
http://img293.imageshack.us/my.php?image=uo0019ty0.jpg
http://img102.imageshack.us/my.php?image=uo0020ar1.jpg
Browser:
http://img102.imageshack.us/my.php?image=uo0021qv3.jpg
Tools:
http://img293.imageshack.us/my.php?image=uo0022qn3.jpg

Lol jak bedziecie chcieli zobaczyc cos wiecej mowcie --
I jeszcze jedno te 2 pliczki w spakowane wyzej ... jak zaczal pojawiac sie ten problem cer teraz to jak te spakowane wrzucilem to ponownie zaczal wyskakiwac "can't find unit system" .... to na razie wszystko ode mnie wiecej pomyslow prosze was ludzie pomozcie ;;;

Pozostało 580 znaków

2006-11-05 19:24
0

Masz napisane "uses cer", zamiast "uses crt"

Pozostało 580 znaków

2006-11-05 19:30
Niewiedza
Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0