[sxskin] problem przy instalacji/użytkowaniu komponentu.

Odpowiedz Nowy wątek
2006-09-07 18:58
0

Witam.

Ostatnio szukałem dobre komponentu, który da mojej aplikacji nietuzinkowy wygląd. Wybrałem http://www.saarixx.info/sxskincomponents/en/ sxskin, powód, jest darmowy [browar] . Ale mam problem z nim, zainstalowałem, ok, dodałem ścieżkę do library patch, ok, działa, tam w folderze example/simple jest programik, który prezentuje jego możliwości, ale jak włączam delphi i odczytuje ten projekt to pojawia się szereg błędów typu: Error reading Panel1.ExplictHeight: Propery Panel1.ExplictHeight does not exist
i coś tam dalej dużo komunikatów, takiej samej tresći. Jak tam ignore all, program działa, ale nie wszystkie jego funkcje działają, jak dam cancel to program nie działa'. Otwieram ten przykład, bo chce zobaczyć jak ze skina korzystać. Co zrobić, by działało.

Kamil

p.s. testowałem na 2005 i 7 i na obu taki sam błąd.

Pozostało 580 znaków

2006-09-13 16:50
Ad
0

Też miałem podobne rzeczy przy innych komponentach. Możliwe, że komponent jest do nowszej wersji Delphi niż ty masz. Z treści errora wynika, że nie istnieje właściwość ExplictHeight komponentu TPanel. Aby to naprawić, musisz otworzyć DFM'a (plik o takiej samej nazwie jak unit, ale z rozszerzeniem DFM - Delphi Form) i znaleźć wpis ExplictHeight. Usuwasz całą linię. Gdy jeszcze raz uruchomisz Delphi, może ci się wyświetlić następny podobny error (np. z ExplictWidth). Analogicznie.
Powodzenia!


Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0