RE 200

0

Mam do uruchomienia pare starych programów. Nie mam ich kodów (i nie wiem w czym są napisane). Gdy je uruchamiam to pojawia się błąd RE 200. Przepuszczałem je przez trzy łatki ściągnięte z neta i nic. Nadal to samo. Moje pytania:

  1. Czy da się je jakoś uruchomić?
  2. Czy istnieją jakieś emulatory na których by działały?
  3. Czy nie da się przywrócić łatki z serwisu 4programmers?
  4. Czy jest możliwe aby ten błąd występował w języku C i czy sa jakieś łatki?
0

RE 200 to "division by zero", czyli jakby program próbował dzielić coś przez zero

0

programy napisane w TP7 z wykorzystaniem modułu CRT tak mają na szynszych komputerach (>200 MHz chyba). Widziałem gdzieś łatkę do tego

0

blad jest w funkcji delay w module CRT, jest on zle zaprogramowany i na szybszych komputerach jest blad, latka jest np w serwisie borlanda, albo na mojej stronce: http://www.wesoledi.end.pl w dziale Programy>TP

(trzeba se reklame robic :-D

// do postu nizej, jesli latki nie dzialaja to sa 2 mozliwosci:

  • zle latkujesz
  • masz blad w programie
0

Wiem czym jest spowodowany ten błąd. Wiem że są łatki. Problem w tym, że nawet po "łatkowaniu" nie działają - patrzcie pytania w poście.

0

Może pomoże, a może nie. Bardzo stara gra Empire DeLuxe for Windows na jednym XP chodziła mi jak złoto, na drugim od razu wywalała General Protection Fault. Dopiero po paru miesiącach (sic!) wpadłem, że na drugim gra była w katalogu o długiej nazwie. I o to chodziło.

0

I w takich sytuacjach przydaje się program DosBox, lub VDMSound... na obu programy z problemem szybkich kompów uruchamiały się i działały swietnie

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0