Problem z debugowaniem programu 64bit

0

Witajcie.
Czy działa komuś z Was debugowanie programu 64bit pod Delphi XE2 + Update2?
Zainstalowaną mam dostepną wersję Trial.
Projekt ma dodaną platformę 64bit, w opcjach projektu w Linking dla Debug Configuration 64bit włączoną mam opcję Include Remote debug symbols, zainstalowany i uruchomiony PAServer, dodany Remote Profil dla tej platformy, połączenie z PAServer jest a po uruchomieniu programu z debugowaniem, nie zatrzymuje się na pułapkach (są błędne, znaczy się z x-em).
Byłbym wdzięczny za jakieś rady, pomysły, jak sobie z tym poradzić.

0

Pewnie klikasz zieloną strzałkę zamiast zielonej strzałki z biedronką żeby uruchomić program(zielona strzałka - run without debugging, zielona strzałka z biedronką - run).

0

hehe, Michał, bez przesady, tyle to ja wiem :P. Debugowanie w 32 bitach działa.

0

Niestety nie mam jak tego sprawdzić, bo delphi xe 2 mam zainstalowane na 32 bitowym XP na wirtualce, ale jak skompiluję na 64 bity, to pułapki są normalne - czerwone kropki, ale nie mogę tego zweryfikować uruchomieniem niestety.

0

Opierałem sie na instrukcji stąd: http://www.devart.com/blogs/dac/?p=6 sekcja debuging

0

Wejdź do:
Project -> Options -> Delphi Compiler -> Compiling -> combo Target -> Debug configuration -> 64-bit Windows platform (po wyborze w combo będzie "Debug configuration - 64-bit") i zaznacz "Debug information" i "Local symbols" (ew. Assertions), a następnie przejdź do "Linking" i zaznacz "Debug information".

Przebilduj projekt, oczywiście przy ustawionym (aktywnym) "Target Platforms" na "64-bit Windows" w menadżerze projektu i musi działać :).

0

Niestety, czy z opcją Include remote debug symbols czy bez niej, nic to nie dało. Dadam że system to Win 7 64bit.
Tak to wygląda:

Linking:
user image

Compiling:
user image

user image

Po uruchomieniu (F9)
user image

0

Podstawowe pytanie to wydaje mi sie bedzie takie, czy ty debugujesz lokalnie czy zdalnie ?
Co co Ci PAServer ?
Jaki masz system tam gdzie masz Delphi a jaki na maszynie na której uruchamiasz ?

0

Starałem się lokalnie debugować. Delphi zainstalowane na Windows 7 64bit PL.
Nie dało się lokalnie, więc próbowałem zdalnie, choć PAServer jest też na tym systemie zainstalowany.
Wszystkiego próbuje, ale nic nie pomaga...

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0