Miganie obiektów

0

Mam kilkanaście obiektów typu TShape na formie, problem polega na tym, że jak uruchomię program to widać migotanie obrazu, wcześniej tego nie było i nie wiem czym to jest spowodowane. Z kolei jak dodam dla formy "DoubleBuffered:=True;" to efekt jest zadowalający tylko pojawia się kolejny problem, gdyż wszystko zaczyna zwalniać, dla przykładu jak mam w procedurze ustawione Sleep(0) to przy tym buforowaniu obiekt nie porusza się tak szybko jak normalnie. Ja się kompletnie nie znam na Delphi, więc można jakoś temu zapobiec?

0

1)

migotanie obrazu

Czyli migotanie TShape, całej formy, całego ekranu ?
Zdecyduj się.

2) Jaki masz system ?

3) Jaki masz komp ? (procek, grafika i Random Access Memory)

0
  1. Migotają wszystkie obiekty na formie.
  2. Windows 7
  3. AMD Athlon Be-2400 - 2.21 Ghz, Gigabyte Radeon HD 3850 512 MB, Kingston 2*1 GB - 800 Mhz
0

AMD Athlon Be-2400 - 2.21 Ghz, Gigabyte Radeon HD 3850 512 MB, Kingston 2*1 GB - 800 Mhz

ort!, myślałem, że słabszy... No i teraz Ci zazdroszczę [wstyd] . Spróbuj wyłączyć Aero (czy jak to się tam nazywa, no nie wiem). PS: Też mam Sevena.
0

Aero mam wyłączone, ogólnie jak włączę ten program to dość mocno obciąża mi procesor, widocznie temu...

0

Nie pamiętam dokładnie ale jedna z dwóch rzeczy:

  1. spróbuj pod TShapy wstawić TPanel
  2. jeżeli masz pod TShape TPanel to go usuń.

Któraś z tych rzeczy powinna pomóc u mnie też tak kiedyś było ...
Nie pytaj dlaczego tak bo nie wiem ;P ale u mnie pomogło ;)

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0