4P dziwnie wolno działa / zalicza zawiechy od kilku dni

Odpowiedz Nowy wątek
2018-05-18 21:24
0

Nie wiem, czy to pasuje do Coyote, czy bardziej do Offtopic, więc jakby co to proszę przenieść ;)

Pytanie - czy Wy też zauważyliście, że w ciągu kilku ostatnich dni (nie umiem dokładnie określić ile, ale raczej nie więcej niż tydzień) 4P ma zawiechy/ zamula się?

Żeby nie było, że to wina mojego łącza lub kompa - stwierdziłem to na 4 komputerach (firmowy, domowy stacjonarny oraz dwa laptopy domowe), z czego połowa ma Win10, a druga Mint 18.2. Nie jest to raczej też kwestia łącza, bo dzieje się to zarówno na domowej kablówce (150/20), firmowym światłowodzie (200/200 z gwarancją) oraz LTE z Plusa.
W czasie, kiedy 4P sie zamula, pingi chodzą, a inne strony otwierają się bez zająknięcia.

Stwierdzone zachowanie objawia się długim wczytywaniem elementów dynamicznych (może nie jest to najlepsze określenie, ale zaraz wyjaśnię o co chodzi). Strona się ładuje OK, a na górze widze, że mam kilka powiadomień. Klikam na "dzwoneczek", rozwija się lista, ale jest pusta i ładne kilka sekund trwa, zanim pojawią się powiadomienia. Albo przed chwilą - dodawałem komentarz do jakiegoś postu, wcisnąłem "wyślij" i przez kilka sekund (na pewno więcej niż 5) był napis "wysyłanie" (czy coś w tym stylu - nie pamiętam dokładnie). Czyli jakby AJAX nie wyrabiał...
Ważna uwaga - nie dzieje się to zawsze, czasami chodzi mega OK, a potem nagle się zamuli na chwilę, po czym wraca do stanu normalnego...

Dajcie proszę znać, czy Wy też zauważyliście coś takiego.


That game of life is hard to play, I'm gonna lose it anyway, The losing card I'll someday lay, So this is all I have to say
Wszystko co dotyczy działania serwisu należy umieszczać tutaj. Tak więc dobrą kategorię wybrałeś. - furious programming 2018-05-18 21:56
Dzięki za odp. Nie byłem pewien, ponieważ Coyote to cały projekt, a to o czym pisałem może wynikać np. z zapchanego serwera albo problemów technicznych na wyjściu serwerowni w świat. A tak przy okazji - czy Ty też coś zauważyłeś, czy póki co jestem jedyny? - cerrato 2018-05-18 21:59
Na razie nie, bo „gram w gre” i nie mam czasu się nad tym zastanawiać. :P - furious programming 2018-05-18 21:59
Wszystko przez te i podobne wątki -> https://4programmers.net/Foru[...]zej_pracy?p=1481024#id1481024 Serwis nie był przygotowany pod obsługę ruchu podobnego do wykop.pl :D - loza_szydercow 2018-05-19 20:30

Pozostało 580 znaków

2018-05-22 13:32
0

Wprowadziłem drobne zmiany. Dajcie znać czy teraz jest lepiej czy gorzej.

Z tego co widzę, póki co jest lepiej. Tak ze 2x lepiej. ;) - furious programming 2018-05-22 16:26

Pozostało 580 znaków

2018-05-28 17:15
0

Nie wiem, czy to efekt placebo, przypadek, niższa ilość aktywności użytkowników związana z sezonem wakacyjnym, a może jednak efekt wprowadzonych przez Adama zmian, ale moim zdaniem teraz jest OK. Od jakiegoś tygodnia nie zauważyłem problemów, których ten wątek dotyczył :)


That game of life is hard to play, I'm gonna lose it anyway, The losing card I'll someday lay, So this is all I have to say
Trolle też mają prawo do wypoczynku i regeneracji. Spokojnie :) - loza_szydercow 2018-05-29 11:57

Pozostało 580 znaków

2018-06-04 12:43
0

Czy wy też dzisiaj widzicie, że forum zamula?

Już wczoraj wieczorem odnosiłem takie wrażenie, dzisiaj na innym kompie i na innym łączu (jestem w firmie) mam to samo - więc raczej wina nie leży po mojej stronie.

Podobnie jak pisałem na początku wątku - nie dzieje się to zawsze. Czasami wszystko idzie błyskawicznie, a potem przez kilka sekund czekam na wyświetlenie się strony. Niestety, nie pomyślałem i nie sprawdziłem czasu generowania - ale organoleptycznie widzę, że coś się znowu dzieje. Dla odmiany - nie dotyczy to jedynie elementów "dynamicznych" (powiadomień, komentarzy, publikowania postów itp.) ale całego ładowania strony.


That game of life is hard to play, I'm gonna lose it anyway, The losing card I'll someday lay, So this is all I have to say
Ale za @kq awansował na pierwsze miejsce w rankingu reputacji! - loza_szydercow 2018-06-04 17:20
@loza_szydercow: Tak poważnie pytając - myślisz, że to ma jakiś związek (nie wiem.. zmasowany atak botów albo coś w tym stylu), czy była to tak rzucona uwaga w formie żartu? - cerrato 2018-06-04 21:24
Ja tu tylko przechodzę i nucę coś pod nosem... :) - loza_szydercow 2018-06-04 21:32

Pozostało 580 znaków

2018-06-06 09:47
0

Widzę, że niestety nadal postgres loguje niektóre zapytania jako "slow query" :( Niby banalne zapytania, podczas EXPLAIN ANALYSE pokazuje Execution time: 0.013 ms, a logi mówią że czasem wykonuje się +500 ms :/

Pozostało 580 znaków

2018-06-06 22:20
0

@Adam Boduch: wciąż zdarza się, że strona generowana jest kilka sekund (przed chwilą – 3.36s).


edytowany 1x, ostatnio: furious programming, 2018-06-06 22:20

Pozostało 580 znaków

2018-06-08 14:06
0

Wyświetlenie strony przed chwilą Coyote 2.2: 5.21 s


That game of life is hard to play, I'm gonna lose it anyway, The losing card I'll someday lay, So this is all I have to say

Pozostało 580 znaków

2018-06-08 15:16
0

Zwiększyłem wartość parametru work_mem. Dajcie znać czy będzie lepiej. Może jest tu ktoś kto mógłby spojrzeć czy takie parametry konfiguracji są ok?

max_connections = 100
shared_buffers = 16GB
effective_cache_size = 48GB
maintenance_work_mem = 2GB
checkpoint_completion_target = 0.7
wal_buffers = 16MB
default_statistics_target = 100
random_page_cost = 1.1
effective_io_concurrency = 200
work_mem = 320MB
min_wal_size = 1GB
max_wal_size = 2GB
max_worker_processes = 8

Ogólnie na serwerze są 64 GB RAM. Nad niektórymi zapytaniami SQL trzeba będzie trochę popracować natomiast baza potrafi się zmulić czasem na banalnych zapytaniach (profiler pokazuje że są wykonywane w milisekunde).

Pokaż pozostałe 2 komentarze
A ja byłem przekonany, że Ty wszystko umiesz :( - cerrato 2018-06-08 16:02
:) nigdy nie wypowiadam się na tematy konfiguracji i rzadko na tematy poprawności bazy... - Marcin.Miga 2018-06-08 16:02
Ale myślałem, że to jedynie kwestia wrodzonej skromności - cerrato 2018-06-08 16:07
A która to wersja postgresa? - yarel 2018-06-13 13:56

Pozostało 580 znaków

2018-06-12 08:38
0

Zrobiłem VACUUM ANALYZE na niektórych tabelach gdzie jest wykonywane wiele zapytań typu INSERT, UPDATE czy DELETE. Dajcie znać czy teraz jest coś lepiej.

Pozostało 580 znaków

2018-06-19 15:33
0
Copyright © 2000-2018 4programmers.net - programowanie i tworzenie stron WWW
Coyote 2.2: 2.76 s

Nadal szału nie ma. Dzieje się to okresowo / falami - przez kilka dni miałem wrażenie, że jest OK, dzisiaj znowu odczuwam spowolnienie.


That game of life is hard to play, I'm gonna lose it anyway, The losing card I'll someday lay, So this is all I have to say
edytowany 1x, ostatnio: cerrato, 2018-06-19 15:33
poczekaj na przenosiny serwera. - szweszwe 2018-06-19 15:52
@szweszwe: serio są planowane jakieś przenosiny, czy nawiązujesz teraz do ziemniaczanego żartu Skarpetki z bloga - https://4programmers.net/Mikroblogi/View/30307#entry-30307 - cerrato 2018-06-19 15:54
no o ten wpis mi chodzi. To był żart? :( - szweszwe 2018-06-19 15:55
Ja to tak odebrałem. Ale nie jestem specem od hardware. Zresztą zastanów się - jakbyś to wepchnął do szafy rackowej? ;) - cerrato 2018-06-19 16:11

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0