Brak vcl60.bpl w komunikatorze???

0

Witajcie
To znowu ja, lecz tym razem mam inny problem...
Stworzyłem tam jakis komunikator i chciałem sprawdzic na innym kompie i wyskoczył błąd że brakuje vcl60.bpl. Czy trzeba cos dokładać do takiego skompilowanego programu, aby nie wyskakiwały podobne błędy?? Jak ktos ma jakiegoś pomysła to będę wdzięczny jak zawsze :). Pozdrowienia

0

He he. To typowy problem przy przenoszeniu programów napisanych w Borlandzie. Zwykle daje się we znaki jak próbujesz uruchomić program pisany w BCB5.0 na BCB6.0 lub odwrotnie :)
Nie napisałeś czy otwierasz swój program na tym drugim kompie w Borlandzie czy po prostu odpalasz na nim execa - to by znacznie pomogło.
Metody są dwie, zależy jak go uruchamiasz: albo znajdź taką bibliotekę na swoim kompie, skopiuj ją i przenieś na tego kompa gdzie uruchamiasz program.
-Jeżeli otwierasz go z Borlanda i pruje się że nie może znaleźć biblioteki vcl60.bpl to podaj mu ścieżkę do niego.
-Jeżeli komunikat pojawia się przy uruchamianiu execa to skopiuj w/w bibliotekę do katalogu z tym execiem.
Druga metoda to:
-przy otwieraniu w Borlandzie: klikaj IGNORUJ dopóki nie skończy się czapić jakich to bibliotek nie może biedacwo otworzyć :). Jak już sobie ulży to w menu PROJECT/OPTIONS|PACKAGES odznacz opcję 'Build with runtime packages' - powinna tam być m.in. wypisana ta biblioteka.
-Najlepsze na koniec: aby zapobiec takim błędom i jeśli błąd pojawia się przy odpalaniu execa, to odznacz tą opcję już U SIEBIE, przed kompilacją programu.

0

Rzeczywiscie odpalam tylko execa, sprobuje tak zrobic jak pisałes. <ort>na razie</ort> dzieki i oczywiscie Pozdrawiam :)

0

Może się mylę, ale odznacz w opcjach Build with runtime packages.

0

A wiec odznaczenie pomogło, ale potrzebował 2 dll i wystartował i tylko tyle dalej cos niedziała z połączeniem, cos z tymi portami jest nie tak... Ale <ort>na razie</ort> dzieki [browar]

0

Bo tak sie zastanawiam ze moze to byc to ze na jednym porcie nasłuchuje i probuje wysałac cos, jak teraz zrobić aby sie jakos przełaczał, czy <ort>w ogóle</ort> zle mysle????

0

Portów nie musisz przełączać - zadbaj tylko o to, żeby klient i serwer mieli ustawione takie same porty (np. 1040). A w ogóle to podeślij mi ten program na [email protected], bo to musi działać :)

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0