CMake - wskazanie OpenSSL

0

Czy jakbym budował w wersji niższej niż 5.12, to problem powinien zostać rozwiązany ?

ale Qt wymaga wyższej i koniec

Podałbyś mi źródło, gdzie oni to zapisali? Ja znalzłem tylko to qt-5-12-4-released-support-openssl-1-1-1 , ale nie połączyłem kropek w głowie, że może to być to.

0

Nie muszę nic szukać, w tym linku który wrzuciłeś jest napisane:

As an important new item it provides binaries build with OpenSSL 1.1.1

Czyli dla tej wersji, jeśli używasz binarek z oficjalnego źródła, musisz użyć openssl 1.1.1. Strzelam, że nie wycięli supportu dla 1.0.2, tak więc być może jest możliwość zbudowania Qt ze źródeł z wersją 1.0.2. Ale to tylko moje gdybanie.

1

Sprawdziłem. Informacja dla potomnych:

Jak ktoś będzie kiedykolwiek miał podoboną sytuację ( ma gdzieś stare API OpenSSL-a ) i potrzebuje Qt 5.12 to ( w chwili pisania tej wiadomości ) 5.12.3 obsługuje starego OpenSSL-a.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0