Biblioteka numeryczna, problem z gsl_integration_romberg_workspace

Odpowiedz Nowy wątek
2019-12-29 21:49

Rejestracja: 1 rok temu

Ostatnio: 1 dzień temu

0

Cześć. Piszę program (w c++) przy użyciu biblioteki gsl (w codeblocksie na windowsie). Dołączam do programu <gsl/gsl_integration.h>, jednak gdy próbuję użyć gsl_integration_romberg_workspace wyskakuje błąd gsl_integration_romberg_workspace was not declarated in this scope . Co zrobić, aby program skompilował się i uruchomił?
Dodam, że sama biblioteka wydaje się być dołączona w poprawny sposób, ponieważ dla przykładu gsl_vector po dołączeniu <gsl/gsl_linalg.h> działa poprawnie.

wrzuć program, po samym błędzie ciężko cokolwiek wywnioskować - heygo1 2019-12-30 23:17

Pozostało 580 znaków

2019-12-30 17:48

Rejestracja: 10 lat temu

Ostatnio: 33 minuty temu

0

Coś namieszałeś w swoim projekcie, bo rzeczona struktura na pewno znajduje się w rzeczonym nagłówku.


Pozostało 580 znaków

2019-12-30 22:57

Rejestracja: 1 rok temu

Ostatnio: 1 dzień temu

0

Jednak używam jej na samym początku programu, sama deklaracja nie przechodzi. Czy może chodzić o wersję biblioteki gsl? Używam wersji 1.8, a powinienem nowszej. Czy tutaj może być problem? Chciałem zainstalować np. 2.5, jednak nie znalazłem nowszej wersji dla windowsa niż właśnie 1.8. Jak mogę to zrobić?

Pozostało 580 znaków

2019-12-30 23:16

Rejestracja: 3 lata temu

Ostatnio: 4 minuty temu

0
hidden55 napisał(a):

Jednak używam jej na samym początku programu, sama deklaracja nie przechodzi. Czy może chodzić o wersję biblioteki gsl? Używam wersji 1.8, a powinienem nowszej. Czy tutaj może być problem? Chciałem zainstalować np. 2.5, jednak nie znalazłem nowszej wersji dla windowsa niż właśnie 1.8. Jak mogę to zrobić?

Klonujesz repo i budujesz sam.

Pozostało 580 znaków

2019-12-31 00:40

Rejestracja: 1 rok temu

Ostatnio: 1 dzień temu

0

A mógłbym prosić o jakieś dokładniejsze wskazówki jak to zrobić? I czy to powinno rozwiązać problem?

Pozostało 580 znaków

2019-12-31 18:48

Rejestracja: 3 lata temu

Ostatnio: 4 minuty temu

0
hidden55 napisał(a):

A mógłbym prosić o jakieś dokładniejsze wskazówki jak to zrobić? I czy to powinno rozwiązać problem?

W osobnym wątku piszesz o problemie z budowaniem na Linuxie, a tu chcesz używać pod Windowsem. To w końcu na jakim systemie chcesz użyć tej biblioteki?

Pozostało 580 znaków

2020-01-01 13:07

Rejestracja: 1 rok temu

Ostatnio: 1 dzień temu

0

Chciałem na windowsie, ale się nie udało, więc teraz próbuję na linuxie. Niestety póki co na żadnym się nie udało

Pozostało 580 znaków

2020-01-01 14:26

Rejestracja: 1 rok temu

Ostatnio: 1 dzień temu

0

Gdyby ktoś kiedyś szukał odpowiedzi - faktycznie chodziło o wersję gsl. Udało mi się zainstalować wersję 2.6 na linuxie i teraz działa. Jeśli chodzi o windowsa niestety wciąż nie udało się zainstalować tam tej wersji.

Pozostało 580 znaków

2020-01-01 15:25

Rejestracja: 3 lata temu

Ostatnio: 4 minuty temu

0
hidden55 napisał(a):

Gdyby ktoś kiedyś szukał odpowiedzi - faktycznie chodziło o wersję gsl. Udało mi się zainstalować wersję 2.6 na linuxie i teraz działa. Jeśli chodzi o windowsa niestety wciąż nie udało się zainstalować tam tej wersji.

Na Windowsie możesz sklonować to repo:

https://github.com/ampl/gsl

A do zbudowania użyć CMake'a, który wygeneruje Ci projekty dla Visual Studio.

Pozostało 580 znaków

Odpowiedz

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0