Wymnożenie wartości histogramu

0

Witam tworzę prosty filtr Gaussa i niestety po kompilacji kodu wyskakuje cały czarny ekran. Wiem dlaczego tak się dzieje, ponieważ wyskakują następujące wyniki:

0.00296902    0.0133062    0.0219382    0.0133062    0.00296902    
0.0133062    0.0596343    0.0983203    0.0596343    0.0133062    
0.0219382    0.0983203    0.162103    0.0983203    0.0219382    
0.0133062    0.0596343    0.0983203    0.0596343    0.0133062    
0.00296902    0.0133062    0.0219382    0.0133062    0.00296902

Jak wiadomo histogram o wartości 0 daje kolor czarny jednak nie umiem tego wymnożyć w kodzie w odpowiedni sposób aby wyniki wyszły widzialne dla obrazu końcowego. Korzystam z tej strony: https://www.geeksforgeeks.org/gaussian-filter-generation-c/ . Jest na niej kod,który można na niej kompilować,proszę o pomoc

0

Co chcesz otrzymać? Jakie wartości są 'widzialne dla obrazu końcowego'?
Czy może masz problem z przemnożeniem tego (dowolnego) filtru przez obraz?

0

Dzięki za zainteresowanie. Chodzi o to, że rozkład wartosci histogramu dla obrazu rozkłada się na przedziale od 0 do 255. Jeżeli wartości w tym przykładzie z linka co wysłałem daje wartości typu 0.16 czy 0.002 to kod programu interpretuje to jako 0 czyli wartość o kolorze czarnym dla całego obrazu. Chciałbym uzyskać wartości nie typu 0.16 tylko powiedzmy 160 albo nie 0.002 tylko 2. Próbowałem wymnożyć wyniki razy 1000 albo 100 ale to nic nie dało bo wyniki końcowe nie zmieniają się i nie wiem jak mam to ugryźć bo wzór dla funkcji gaussa jest tylko jeden, ten który jest tam u góry w linku.

0

Podczas mnożenia filtru przez obraz powinna być normalizacja więc nie powinno być problemu z pomnożeniem wszystkich wartości filtru przez stałą.

kod programu interpretuje to jako 0

Algorytm działa na liczbach całkowitych?

0

Próbowalem wymnożyć przy normalizacji ale też nie reaguje, więc już sam nie wiem czy korzystam z dobrego kodu bo może dla obrazów jest inny algorytm dla gaussa.

0

Dla innych filtrów działa?
Zobacz ten:

\begin{bmatrix}     1 & 1 & 1 & 1  & 1 \\     1 & 1 & 1 & 1  & 1 \\     1 & 1 & 1 & 1  & 1 \\     1 & 1 & 1 & 1  & 1 \\     1 & 1 & 1 & 1  & 1 \\ \end{bmatrix}

oraz ten:

\begin{bmatrix}     1 & 2 & 4 & 2  & 1 \\     2 & 4 & 8 & 4  & 2 \\     4 & 8 & 16 & 8  & 4 \\     2 & 4 & 8 & 4  & 2 \\     1 & 2 & 4 & 2  & 1  \end{bmatrix}
0

Maska tu na razie nie gra roli bo wszystkie filtry na razie robie na masce o wartosciach 1. Zmieniłem tą linie kodu : exp(-(rr) / (2 sigmasigma)) / (2 M_PIsigmasigma); i lena zaczęła się pojawiać jednak nie widzę efektu rozmycia tylko tak jakby była bardziej rozświetlona. Dziwne

0

Jeżeli algorytm działa dla maski

\begin{bmatrix}     1 & 1 & 1 & 1  & 1 \\     1 & 1 & 1 & 1  & 1 \\     1 & 1 & 1 & 1  & 1 \\     1 & 1 & 1 & 1  & 1 \\     1 & 1 & 1 & 1  & 1 \\ \end{bmatrix}

to zrób by działał dla maski

\begin{bmatrix}     10 & 10 & 10 & 10  & 10 \\     10 & 10 & 10 & 10  & 10 \\     10 & 10 & 10 & 10  & 10 \\     10 & 10 & 10 & 10  & 10 \\     10 & 10 & 10 & 10  & 10 \\ \end{bmatrix}

Bez normalizacji nie zadziała.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0