Problem z kompilatorami

0

Witam!

Jestem kompletnym nowicjuszem i mam problem z kompilatorami, a wygląda to następująco: na Dev-C++ napisałem "program"(hello world) skompilowałem i chciałem go uruchomić to okienko programowe w milisekundzie się pojawiało i od razu znikało, natomiast w Code::Blocks wyskakuje mi błąd: "Hellow - Debug" uses an invalid compiler. Probably the toolchain path within the compiler options is not setup correctly ?! Skipping...
Nie wiem co mam zrobić :( Proszę o pomoc.

0

w milisekundzie się pojawiało i od razu znikało

O ile nie wystąpił jakiś dziwny błąd, to wszystko jest dobrze.
Konsola ma wykonywać swoje zadanie i się zamykać.

0

Ale dlaczego ja nie mogę zobaczyć okna programu ?

0

Wróżka na urlopie, wstaw tu kod najlepiej.

Jeśli chcesz zatrzymać działanie programu to dodaj system("pause").

0

Dałem Build and Run. Jeżeli nie tak to jak to się robi ? :(
Poprawka: Sorki rzeczywiście nie podałem kilku ważnych informacji ;) Chodzi mi o programowanie w C, a system to Windows XP.

0

Mam tak:

#include <stdio.h>

int main (void)
{
     printf ("Hello World!");
     system ("pause") (próbowałem też z getchar (); )
     return 0;
}

Daje Build and Run i nic nie wyskakuje tylko ten sam błąd co pisałem wcześniej :(

0

No i masz źle :P

Nie pamiętasz o średnikach, nie dodałeś stdlib.h, więc kompilator nie wie, skąd mu instrukcje dajesz.

Powinno być:


#include <stdio.h>
#include <stdlib.h>

int main (void)
{
     printf ("Hello World!");
     system ("pause");
     return 0;
}

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0