Z jakich dll korzysta program?

0

Witam,
piszę program korzystający zarówno z CUDA jak i OpenGL w wersji 64bit.
Na moim komputerze (developerskim) działa, na drugim nie (pojawia się błąd: Aplikacja nie została właściwie uruchomiona (0cx000007b)). Patrząc na błąd wygląda na to, że na drugim komputerze nie ma 64 bitowej wersji jakiegoś dll'a i system próbuje radzić sobie z wersją 32 bitową co mu nie wychodzi.
Problemem jest OpenGL, bo po wyłączeniu klasy wyświetlania z builda program odpala się normalnie.
Niestety nie mogę dojść, którego dll'a brakuje (szukam po rozszerzeniach i wydaje mi się, że wszystkie dołączam po folderu z programem, ale w dalszym ciągu czegoś brakuje).

Czy da się w jakiś sposób sprawdzić z jakich dll korzysta program w trakcie swojego działania?

0

Np. Dependency Walker

0

Pod Linuksem by wystarczyło ldd...
np.

[email protected]:~$ ldd '/home/jason/Projekty/TooManyTroopers/TooManyTroopers' 
    linux-gate.so.1 =>  (0xb779e000)
    libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0xb76d3000)
    libpthread.so.0 => /lib/i686/cmov/libpthread.so.0 (0xb76ba000)
    libGL.so.1 => /usr/lib/libGL.so.1 (0xb7654000)
    libGLU.so.1 => /usr/lib/libGLU.so.1 (0xb75e4000)
    libSDL_mixer-1.2.so.0 => /usr/lib/libSDL_mixer-1.2.so.0 (0xb758c000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7497000)
    libm.so.6 => /lib/i686/cmov/libm.so.6 (0xb7471000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7453000)
    libc.so.6 => /lib/i686/cmov/libc.so.6 (0xb730c000)
    libasound.so.2 => /usr/lib/libasound.so.2 (0xb7244000)
    librt.so.1 => /lib/i686/cmov/librt.so.1 (0xb723b000)
    libdl.so.2 => /lib/i686/cmov/libdl.so.2 (0xb7237000)
    libdirectfb-1.2.so.9 => /usr/lib/libdirectfb-1.2.so.9 (0xb71c2000)
    libfusion-1.2.so.9 => /usr/lib/libfusion-1.2.so.9 (0xb71b8000)
    libdirect-1.2.so.9 => /usr/lib/libdirect-1.2.so.9 (0xb71a4000)
    libvga.so.1 => /usr/lib/libvga.so.1 (0xb7143000)
    /lib/ld-linux.so.2 (0xb779f000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0xb7026000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0xb7017000)
    libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0xb7011000)
    libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb700e000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb7009000)
    libdrm.so.2 => /usr/lib/libdrm.so.2 (0xb6fff000)
    libmikmod.so.2 => /usr/lib/libmikmod.so.2 (0xb6fb3000)
    libvorbisfile.so.3 => /usr/lib/libvorbisfile.so.3 (0xb6faa000)
    libsmpeg-0.4.so.0 => /usr/lib/libsmpeg-0.4.so.0 (0xb6f52000)
    libx86.so.1 => /lib/libx86.so.1 (0xb6f4f000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6f36000)
    libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0xb6f0d000)
    libogg.so.0 => /usr/lib/libogg.so.0 (0xb6f07000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0xb6f04000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6eff000)

Swoją drogą to o ile się orientuję, CUDA wymagają zainstalowanych specjalnych sterowników do karty graficznej.

0

Dzięki! :-D
pomogło :-D

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0