Problem z dzialaniem skompilowanego projektu OGRE

0

Witam.
Używam VC++8 i ogre. Poprawnie zainstalowałem OGRE, platform SDK x86, directX SDK, i wszystko czego wymagał ogre.
problem tkwi w tym, że projekt sie kompiluje i uruchamia(F5), wida główne okienko FPS itd. lecz jest puste, pomimo, że nawet daje poprawne kody z sampli, lecz po zamknięciu exe ka w solution Explorer pojawia sie coś takiego :

'ggg.exe': Loaded 'C:\OgreSDK\bin\debug\ggg.exe', Symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\ntdll.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\kernel32.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\OgreSDK\bin\debug\OgreMain_d.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\user32.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\gdi32.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.VC80.DebugCRT_1fc8b3b9a1e18e3b_8.0.50727.762_x-ww_5490cd9f\msvcp80d.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.VC80.DebugCRT_1fc8b3b9a1e18e3b_8.0.50727.762_x-ww_5490cd9f\msvcr80d.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\msvcrt.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\OgreSDK\bin\debug\OIS_d.dll', Binary was not built with debug information.
'ggg.exe': Loaded 'C:\WINDOWS\system32\dinput8.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\advapi32.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\rpcrt4.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\oleaut32.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\ole32.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\wininet.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\shlwapi.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\crypt32.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\msasn1.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.2180_x-ww_a84f1ff9\comctl32.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\urlmon.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\version.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\psapi.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\OgreSDK\bin\debug\RenderSystem_Direct3D9_d.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\d3d9.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\d3d8thk.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\winmm.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\uxtheme.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\OgreSDK\bin\debug\RenderSystem_GL_d.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\opengl32.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\glu32.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\ddraw.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\dciman32.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\MSCTF.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\atioglxx.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\mcd32.dll', No symbols loaded.
'ggg.exe': Unloaded 'C:\WINDOWS\system32\mcd32.dll'
'ggg.exe': Loaded 'C:\OgreSDK\bin\debug\Plugin_ParticleFX_d.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\OgreSDK\bin\debug\Plugin_BSPSceneManager_d.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\OgreSDK\bin\debug\Plugin_OctreeSceneManager_d.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\OgreSDK\bin\debug\Plugin_CgProgramManager_d.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\OgreSDK\bin\debug\cg.dll', Binary was not built with debug information.
First-chance exception at 0x7c81eb33 in ggg.exe: Microsoft C++ exception: Ogre::InvalidParametersException at memory location 0x0012e594..
'ggg.exe': Loaded 'C:\WINDOWS\system32\hid.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\setupapi.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\wintrust.dll', No symbols loaded.
'ggg.exe': Loaded 'C:\WINDOWS\system32\imagehlp.dll', No symbols loaded.
First-chance exception at 0x7c81eb33 in ggg.exe: Microsoft C++ exception: OIS::Exception at memory location 0x0012f650..
The thread 'Win32 Thread' (0x9b8) has exited with code 0 (0x0).
'ggg.exe': Unloaded 'C:\OgreSDK\bin\debug\Plugin_CgProgramManager_d.dll'
'ggg.exe': Unloaded 'C:\OgreSDK\bin\debug\cg.dll'
'ggg.exe': Unloaded 'C:\OgreSDK\bin\debug\Plugin_OctreeSceneManager_d.dll'
'ggg.exe': Unloaded 'C:\OgreSDK\bin\debug\Plugin_BSPSceneManager_d.dll'
'ggg.exe': Unloaded 'C:\OgreSDK\bin\debug\Plugin_ParticleFX_d.dll'
'ggg.exe': Unloaded 'C:\OgreSDK\bin\debug\RenderSystem_GL_d.dll'
'ggg.exe': Unloaded 'C:\WINDOWS\system32\opengl32.dll'
'ggg.exe': Unloaded 'C:\WINDOWS\system32\ddraw.dll'
'ggg.exe': Unloaded 'C:\WINDOWS\system32\dciman32.dll'
'ggg.exe': Unloaded 'C:\WINDOWS\system32\glu32.dll'
'ggg.exe': Unloaded 'C:\OgreSDK\bin\debug\RenderSystem_Direct3D9_d.dll'
The program '[3068] ggg.exe: Native' has exited with code 0 (0x0).

Proszę o pomoc w rozwiązaniu problemu.
PS.
Myslalem ze to wina DIRECTX, lecz zainsatlowalem 9.0c i dalej ten sam problem :/.

user image

0

jesli naciskasz F5 to to wlasnie odpalasz pewnie w trybie debug*).. i skoro VS nie wylapuje skad leci except, a to znaczy ze exception ten jest juz lapany i jest wygaszany.. tak wiec masz loterie, ew. czekanie az sie znajdzie ktos kto tez mial czarny ekran zamiast sceny.. w ogole jestes pewien ze aplikacja jest napisana prawidlowo, tzn. w sensie inicjalizacji ogre itp starterow? proponuje postawic pare breakow w miejscach gdzie na starcie inicjalizujesz ogre i okoliczne i obserwowac okinko 'output' (bo ten zrzut tekstu z niego pochodzi) i stepowac az sie ten log o exceptionie pojawi.. wtedy bedziesz mial info mniejwiecej o jakie paramsy moze chodzic (invalidparametersexception)..

edit: *) a jesli nie odpalasz w debug tylko release, to przelacz na debug i pusc program. mze bedziesz mial szczescie i VS zlapie skad to leci, albo tez moze na jakims assercie sie wywali..

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0