Budowanie aplikacji

0

Jak zbudować w visualu aplikację nie używającej platformy .NET 2.0 a już najlepiej też 1.1? (Tak by program wyglądał jak wygląda, ale żeby nie wymagał tych platform zainstalowanych na komputerze użytkownika (wiem, że komponenty będą nieco inaczej wyglądać))???

0

nie da sie... vs2005 jest do .net 2.0
vs2003 do .net 1.1
vs2002 do .net 1.0

tak czy siak framework'a zawsze bedziesz potrzebowal. Niby mozna jakos wykombinowac by budowac z vs2005 aplikacje .net 1.1 ale to sie raczej mija z celem (probowalem, wiecej problemu niz pozytku).

0

Dodam, że .NET Framework 1.1 jest standardowo w Windows XP SP2 i Windows 2003, a .NET 2.0 jest w Windows Vista i (chyba) Windows 2003 R2. W takim wypadku użytkownik nie musi niczego doinstalowywać.

A C# jest językiem tylko i wyłącznie dla .NET, nic się bez niej zrobić nie da.

0

No tak ale ja piszę aplikację dla firmy, w której na 10 kompów aż jeden na Win XP i to pewnie bez SP2. I nie jestem pewien czy da się te platformy na win 98 wrzucić...

0

Da się. .NET Framework 2.0:

System Requirements

* Supported Operating Systems: Windows 2000 Service Pack 3; Windows 98; Windows 98 Second Edition; Windows ME; Windows Server 2003; Windows XP Service Pack 2

* Required Software:

  o Windows Installer 3.0 (except for Windows 98/ME, which require Windows Installer 2.0 or later). Windows Installer 3.1 or later is recommended.
  o IE 5.01 or later: You must also be running Microsoft Internet Explorer 5.01 or later for all installations of the .NET Framework.
* Disk Space Requirements: 280 MB (x86), 610 MB (x64)
0

W Windows Vista bedzie .net 3.0 :)

0
wasiu napisał(a)

W Windows Vista bedzie .net 3.0 :)

Haha śmieszny jesteś :-)
Jak juz to 2.1 (Chociaz watpie ;])
na pewno i raczej wyłącznie będzie tam tylko .NET 2.0

0

Mylisz się.
W Windows Vista naprawdę będzie .NET 3.0, czyli praktycznie WinFx (Windows Presentation Foundation, Windows Communication Foundation, Windows Workflow Foundation) tak w gruncie rzeczy.

U mnie na jest katalog C:\Windows\Microsoft.NET\Framework a w nim podkatalogi v1.0.3705, v1.1.4322, v2.0.50727, v3.0. Używam Microsoft Windows Vista Ultimate RC2 (build 5744).

A jeśli potrzebujesz .NET 3.0:
http://www.microsoft.com/down[...]788825C1AF&displaylang=en

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0