Windows Authentification w Blazor Server Side

0

Witam,

Przyznam, że dopiero zaczynam przygodę i próbuję jakoś sobie wiedze (szczątkową) poukładać.
Sytuacja jest następująca.
Są trzy elementy, wszystkie w tej samej sieci

  • komputer użytkownika
  • VM z zainstalowanym Windows 10 server i IIS
  • VM z zainstalowanym SQL server

Stworzyłem w Visual Studio projekt Blazor Server Side i podczas jego tworzenia wybrałem Windows Authentification.
Stworzył dodatkowo możliwość wczytania jakichś randomowych danych z servera za pomocą guzika. Nie korzystam z API tylko mam hardcoded conn string (ustawiony na windows Authentification) i strzelam na baze SLQ. Wiem, że tak się nie robi, ale na tą chwilę chciałem sprawdzić czy rozumiem temat (ewidentnie nie).

Jak odpalam projekt (przez VS) to w prawym górnym rogu www pojawia się mój login - i to jest git.
Guzik też działa, klikam i wczytuje się coś tam z bazki.

Zrobiłem self-contained build i wgrałem na VM i host w IIS.

Niestety jak się użytkownik wbije na tą stronkę to już nie ma w prawym górnym logu lego loginu. Oraz guzik też nie działa.
Ja wiem, że to pewnie coś prostego i głupiego, nie mniej potrzebowałbym jakiejś porady.

I tutaj dochodzimy niestety do momentu mojego nie zrozumienia Autentyfikacji. Moje wyobrażenie jest takie, że w momencie kiedy użytkownik wbija się na www, to wtedy jest robiony 'jakiś' call z zapytaniem 'kim ty jesteś' i w przypadku win auth to ponownie 'jakoś' windows mówi, że to jest taki i taki ziomek. Niestety przez to, że w momencie odpalenia strony z VM IIS ten login się nie wyświetla to coś ostro mylę.

0

IISa skonfigurowałeś?

mojego nie zrozumienia Autentyfikacji

=> tego sposobu uwierzytelniania

1

Ok, faktycznie nie.
Nie mniej w IIS jak wejdę w zakładkę Authentification to nie mam tam dostępnego Windows Authentification - a google powiedziało że powinno być.
Mam tylko
Anonymous
APS .Net Impersonation.

Szybkie sprawdzenie w googla podpowiedziało, ze musze doinstalować tą paczkę, nie mniej sprawdziłem w konfiguracji i takową mam zainstalowaną.

Edit!
Stackoverflow prawdę Ci powie.
Nie wiem czemu, ale ktoś tam zasugerował aby włączyć IIS Manager jako Admin. podziałało :)

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0