Visual Studio Community 2017 problem

0

Cześć

Z tej stron Artur. Jestem nowy na forum. Od razu witam wszystkich.

Uczę się języka programowania C#. Zainstalowałem Visual Studio Community 2017. Przez tydzień czasu nie miałem problemów. Od wczoraj jak włączam VS pojawiają się błędy.Wyskakuje informacja, że nie mogą się załadować moduły między innymi: 'General diagnostics about the running VS session'; 'Microsoft.VisualStudio.PlatformUI.SolutionNavigatorPackage'; 'ExtensionManagerPackage' i kilka innych przy okazji. VS działa, ale na przykład okienko Solution Explorer jest nie aktywne. Wyskakuje w nim informacja, że jest błąd i tyle. Nie można pracować w VS. Instalowałem kilka razy i to samo.

Skopiowałem błędy z logów. Proszę o pomoc.

Activity Monitor Log
infos 157
warnings 0
errors 18

#

Type

Description

GUID

Hr

Source

Time (UTC)

15 ERROR Error attempting to restore App Path
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\devenv.exe 80070005 - E_ACCESSDENIED VisualStudio 2017/04/04 17:56:23.209

35 ERROR LegacySitePackage failed for package [General diagnostics about the running VS session]Source: 'Microsoft.VisualStudio.Shell.UI.Internal' Description: Nie można załadować typu 'Microsoft.VisualStudio.Shell.IOleMenuCommand' z zestawu 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. System.TypeLoadException: Nie można załadować typu 'Microsoft.VisualStudio.Shell.IOleMenuCommand' z zestawu 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. at Microsoft.VisualStudio.PlatformUI.Diagnostics.DiagnosticsPackage.Initialize() at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp) {7D1A598C-4F97-4A83-A178-6B1BFCC7061E} 80131522 VisualStudio 2017/04/04 17:56:23.616

36 ERROR SetSite failed for package General diagnostics about the running VS session {7D1A598C-4F97-4A83-A178-6B1BFCC7061E} 80131522 VisualStudio 2017/04/04 17:56:23.631

37 ERROR End package load [General diagnostics about the running VS session] {7D1A598C-4F97-4A83-A178-6B1BFCC7061E} 80131522 VisualStudio 2017/04/04 17:56:23.631

88 ERROR LegacySitePackage failed for package [Microsoft.VisualStudio.PlatformUI.SolutionNavigatorPackage]Source: 'Microsoft.VisualStudio.Shell.UI.Internal' Description: Could not load type 'Microsoft.VisualStudio.Shell.IOleMenuCommand' from assembly 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. System.TypeLoadException: Could not load type 'Microsoft.VisualStudio.Shell.IOleMenuCommand' from assembly 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. at Microsoft.VisualStudio.PlatformUI.SolutionNavigatorPackage.Initialize() at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp) {CF6A5C16-83B0-4D04-B702-195C35C6E887} 80131522 VisualStudio 2017/04/04 17:58:06.828

89 ERROR SetSite failed for package Microsoft.VisualStudio.PlatformUI.SolutionNavigatorPackage {CF6A5C16-83B0-4D04-B702-195C35C6E887} 80131522 VisualStudio 2017/04/04 17:58:06.844

90 ERROR End package load [Microsoft.VisualStudio.PlatformUI.SolutionNavigatorPackage] {CF6A5C16-83B0-4D04-B702-195C35C6E887} 80131522 VisualStudio 2017/04/04 17:58:06.844

94 ERROR Construction of frame content failed. Frame identifier: ST:0:0:{3ae79031-e1bc-11d0-8f78-00a0c9110057} Frame caption: Solution Explorer Exception details: System.TypeLoadException: Failure has occurred while loading a type. at Microsoft.VisualStudio.Shell.Interop.IVsShell5.LoadPackageWithContext(Guid& packageGuid, Int32 reason, Guid& context) at Microsoft.VisualStudio.Platform.WindowManagement.WindowFrame.GetPackage() at Microsoft.VisualStudio.Platform.WindowManagement.WindowFrame.ConstructContent() VisualStudio 2017/04/04 17:59:32.026

120 ERROR SetSite failed for package [ExtensionManagerPackage]Source: 'Microsoft.VisualStudio.ExtensionManager.Implementation' Description: Could not load type 'Microsoft.VisualStudio.Shell.IOleMenuCommand' from assembly 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. System.TypeLoadException: Could not load type 'Microsoft.VisualStudio.Shell.IOleMenuCommand' from assembly 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. at Microsoft.VisualStudio.ExtensionManager.VSPackage.ExtensionManagerPackage.<initializeasync>d27.MoveNext() at System.Runtime.CompilerServices.AsyncTaskMethodBuilder.Start[TStateMachine](TStateMachine& stateMachine) at Microsoft.VisualStudio.ExtensionManager.VSPackage.ExtensionManagerPackage.InitializeAsync(CancellationToken cancellationToken, IProgress`1 progress) at Microsoft.VisualStudio.Shell.AsyncPackage.<>cDisplayClass16_0.<<microsoft-visualstudio-shell-interop-iasyncloadablepackageinitialize-initialize>b__1>d.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at Microsoft.VisualStudio.Services.VsTask.RethrowException(AggregateException e) at Microsoft.VisualStudio.Services.VsTask.InternalGetResult(Boolean ignoreUIThreadCheck) at Microsoft.VisualStudio.Services.VsTask.GetResult() {E7576C05-1874-450C-9E98-CF3A0897A069} 80131522 VisualStudio 2017/04/04 17:59:32.853

121 ERROR End package load [ExtensionManagerPackage] {E7576C05-1874-450C-9E98-CF3A0897A069} 80131522 VisualStudio 2017/04/04 17:59:32.853

153 ERROR SetSite failed for package [ExtensionManagerPackage]Source: 'Microsoft.VisualStudio.ExtensionManager.Implementation' Description: Could not load type 'Microsoft.VisualStudio.Shell.IOleMenuCommand' from assembly 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. System.TypeLoadException: Could not load type 'Microsoft.VisualStudio.Shell.IOleMenuCommand' from assembly 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. at Microsoft.VisualStudio.ExtensionManager.VSPackage.ExtensionManagerPackage.<initializeasync>d27.MoveNext() at System.Runtime.CompilerServices.AsyncTaskMethodBuilder.Start[TStateMachine](TStateMachine& stateMachine) at Microsoft.VisualStudio.ExtensionManager.VSPackage.ExtensionManagerPackage.InitializeAsync(CancellationToken cancellationToken, IProgress`1 progress) at Microsoft.VisualStudio.Shell.AsyncPackage.<>cDisplayClass16_0.<<microsoft-visualstudio-shell-interop-iasyncloadablepackageinitialize-initialize>b__1>d.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at Microsoft.VisualStudio.Services.VsTask.RethrowException(AggregateException e) at Microsoft.VisualStudio.Services.VsTask.InternalGetResult(Boolean ignoreUIThreadCheck) at Microsoft.VisualStudio.Services.VsTask.GetResult() {E7576C05-1874-450C-9E98-CF3A0897A069} 80131522 VisualStudio 2017/04/04 18:00:33.595

154 ERROR End package load [ExtensionManagerPackage] {E7576C05-1874-450C-9E98-CF3A0897A069} 80131522 VisualStudio 2017/04/04 18:00:33.595

162 ERROR LegacySitePackage failed for package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]Source: 'Microsoft.VisualStudio.Editor.Implementation' Description: Object reference not set to an instance of an object. System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.VisualStudio.Editor.Implementation.EditorParts.get_ContentTypeRegistryService() at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.MakeLanguageServiceContentTypes(SettingsStore settingsStore) at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.InitLanguageServiceToContentTypeMapper(IServiceProvider serviceProvider) at Microsoft.VisualStudio.Editor.Implementation.EditorPackage.Initialize() at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp) {E269B994-EF71-4CE0-8BCD-581C217372E8} 80004003 - E_POINTER VisualStudio 2017/04/04 18:01:25.095

163 ERROR SetSite failed for package Microsoft.VisualStudio.Editor.Implementation.EditorPackage {E269B994-EF71-4CE0-8BCD-581C217372E8} 80004003 - E_POINTER VisualStudio 2017/04/04 18:01:25.095

167 ERROR End package load [Microsoft.VisualStudio.Editor.Implementation.EditorPackage] {E269B994-EF71-4CE0-8BCD-581C217372E8} 80004003 - E_POINTER VisualStudio 2017/04/04 18:01:25.095

173 ERROR LegacySitePackage failed for package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]Source: 'Microsoft.VisualStudio.Editor.Implementation' Description: Object reference not set to an instance of an object. System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.VisualStudio.Editor.Implementation.EditorParts.get_ContentTypeRegistryService() at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.MakeLanguageServiceContentTypes(SettingsStore settingsStore) at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.InitLanguageServiceToContentTypeMapper(IServiceProvider serviceProvider) at Microsoft.VisualStudio.Editor.Implementation.EditorPackage.Initialize() at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp) {E269B994-EF71-4CE0-8BCD-581C217372E8} 80004003 - E_POINTER VisualStudio 2017/04/04 18:01:26.713

174 ERROR SetSite failed for package Microsoft.VisualStudio.Editor.Implementation.EditorPackage {E269B994-EF71-4CE0-8BCD-581C217372E8} 80004003 - E_POINTER VisualStudio 2017/04/04 18:01:26.713

175 ERROR End package load [Microsoft.VisualStudio.Editor.Implementation.EditorPackage] {E269B994-EF71-4CE0-8BCD-581C217372E8} 80004003 - E_POINTER VisualStudio 2017/04/04 18:01:26.713

0

Spróbuj zmienić nazwę wyróżnionego folderu w podanej ścieżce: C:\Users\%username%\AppData\Local\Microsoft\VisualStudio\"numer wersji"\ ComponentModelCache. Nowa nazwa może być byle jaka. Chodzi w tym wszystkim o to, że powinno się ten folder wyczyścić, ale lepiej zmienić jego nazwę i zachować pliki dla bezpieczeństwa.

0
dub.raf napisał(a):

Spróbuj zmienić nazwę wyróżnionego folderu w podanej ścieżce: C:\Users\%username%\AppData\Local\Microsoft\VisualStudio\"numer wersji"\ ComponentModelCache. Nowa nazwa może być byle jaka. Chodzi w tym wszystkim o to, że powinno się ten folder wyczyścić, ale lepiej zmienić jego nazwę i zachować pliki dla bezpieczeństwa.

Nie pomogło kolego. Usunięcie plików z folderu również nic nie daje.

0

hmmmm, w takim razie zastosuj się do wytycznych podanych na tych stronach:
https://developercommunity.vi[...]2017-enterprise-on-windo.html
https://developercommunity.vi[...]-start-the-visual-studio.html

Z tego co widzę to wielu użytkowników ma z tym problem :/

0
dub.raf napisał(a):

hmmmm, w takim razie zastosuj się do wytycznych podanych na tych stronach:
https://developercommunity.vi[...]2017-enterprise-on-windo.html
https://developercommunity.vi[...]-start-the-visual-studio.html

Z tego co widzę to wielu użytkowników ma z tym problem :/

Jutro to sprawdzę na spokojnie i dam znać. Ostatnio odebrałem przesyłkę z książkami do C# to przynajmniej alternatywnie mam się z czego uczyć. Dzięki za pomoc.

0

Nie działają te sposoby. Miał ktoś z Was ten problem?

0

Cały czas nie mogę rozwiązać problemu z VS Community 2017. Czy Visual Studio Expess 2013 różni się bardzo od Community 2017? Na obecną chwile VS służy mi do nauki podstaw i średnio zaawansowany poziom. Przerabiam ASP.NET MCV 5.

0

Temat do zamknięcia. Zainstalowałem VS Express 2013. Musiałem przesiąść się na starszą wersję VS, ponieważ nie miałem na czym pracować. VS Community 2017 działa prawidłowo i mam dwie zainstalowane wersje. Prawdopodobnie chodzi o łatkę KB2829760, która się doinstalowała.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0