opublikowanie aplikacji webowej mvc

Odpowiedz Nowy wątek
2015-01-31 12:49
0

Hej,

w debugerze wszystko ładnie chodzi. Publikuję aplikację na serwer do podkatalogu i nie wszystko działa jak należy.
Co muszę zmienić aby aplikacja chodziła z podkatalogu? Wiem, że nie widzicie kodu jednak proszę i wskazówki.

Czy może w RouteConfig.cs?

Pozostało 580 znaków

2015-01-31 13:29
dexter90
0

A jaki masz komunikat jak wrzucisz aplikację na IIS? Czy Twój własny serwer ma zainstalowane komponenty dla IIS do MVC?

Pozostało 580 znaków

2015-01-31 13:55
0

publikuję sobie do katalogu i potem przegrywam go na serwer. Potem z poziomu serwera dodaję aplikację i wskazuję mój katalog.

i teraz np. http:/adresIP/katalog/controller/akcja

mam stronę logowania, loguję się i przekierowuje mnie na http://adresIP
gdy ręcznie odpalę np. http://adresIP/katalog/kontroler/akcja - wszystko chodzi

Pozostało 580 znaków

2015-01-31 16:31
ne0
0

pokaż zawartość swojego RouteConfig i web.config


Pomogłem? To dobrze :)
edytowany 1x, ostatnio: ne0, 2015-01-31 16:31

Pozostało 580 znaków

2015-01-31 17:48
Krwawy Krawiec
0

RouteConfig, w sumie jest standardowy. Nie próbowałem jeszcze po prostu w url przed {controller} dodać katalog. Ale w sumie sam nie wiem tak na sztywno?

public static void RegisterRoutes(RouteCollection routes) {
            routes.IgnoreRoute("{resource}.axd/{*pathInfo}");
            routes.IgnoreRoute("{resource}.ashx/{*pathInfo}");

            routes.MapRoute(
                name: "Default", // Route name
                url: "{controller}/{action}/{id}", // URL with parameters
                defaults: new { controller = "Home", action = "Index", id = UrlParameter.Optional } // Parameter defaults
            );
        }

Pozostało 580 znaków

2015-01-31 19:36
ne0
0

No to ten RouteConfig wygląda OK. Pytanie jeszcze czy w konfiguracji konta hostingowego czegoś nie brakuje albo trzeba inaczej ustawić.


Pomogłem? To dobrze :)

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0