Problem z instalacją Firebird

Odpowiedz Nowy wątek
2006-11-16 12:44
0

Cześć. Próbowałem zainstalować Firebirda 1.5(classic server) na czystym Windowsie XP. Zainstalowało się, wszystkie procesy, jakie powinny być uruchomione - były. Natomiast nie można połączyć się do bazy. Po kilku minutach wyskakuje komunikat, że nie można było się połączyć.

Ten problem mam już na drugim komputerze(na dwóch innych z tym samym XP) wszystko działa. Czy ktoś z Was miał już kiedyś taki problem?

Pozostało 580 znaków

2006-11-16 14:09
0
  1. odnośnie CS poczytaj sobie to http://gskoczylas.rekord.pl/i[...]ebird/ClassicSuperServer.html
  2. jak jest dobrze zainstalowany to nie ma z nim problemu
  3. łączysz się z tego samego kompa
  4. jak się łączysz
  5. nie miałeś tam starego pliku security.fdb z innymi hasłami :>

- Ciemna druga strona jest.
- Nie marudź Yoda, tylko jedz tego tosta.
Google NIE GRYZIE!
Pomogłem - kliknij

Pozostało 580 znaków

2006-11-20 08:45
0

Ja bym strzelał w Windowsowego firewalla - port 3050 odblokuj

Pozostało 580 znaków

2006-11-20 15:33
0
Misiekd napisał(a)
  1. odnośnie CS poczytaj sobie to http://gskoczylas.rekord.pl/i[...]ebird/ClassicSuperServer.html

Nic tam nowego się nie dowiedziałem

  1. jak jest dobrze zainstalowany to nie ma z nim problemu

Z instalki ściągniętej z ichniej strony. Poza tym, na dwóch kompach działa z tej samej instalki, na 4 pozostałych nie :|

  1. łączysz się z tego samego kompa

Tak

  1. jak się łączysz

Dobrze ;)
Nie chodzi nawet, gdy wywołuję GSEC z odpowiednimi parametrami

  1. nie miałeś tam starego pliku security.fdb z innymi hasłami :>

Nie, komp w miarę czysty.

A jeśli chodzi o zaporę, to jest wyłączona

Pozostało 580 znaków

2006-11-20 16:27
0

a serwis w ogóle Ci startuje :>


- Ciemna druga strona jest.
- Nie marudź Yoda, tylko jedz tego tosta.
Google NIE GRYZIE!
Pomogłem - kliknij

Pozostało 580 znaków

2006-11-21 00:24
0

A do serwera się łączy, np ibconsolą?
Może plik ".gdb" jest "tylko do odczytu" lub uszkodzony?
Może masz program mks vir (arca vir) z firewallem i kontrolą rejestru? Wtedy grubsze sztuczki - nawet gdy się go wyłaczy to dalej blokuje połączenie z bazą - nawet lokalnie (dobre, bo polskie). Trzeba wyłączyć mks`a, resart kompa reinstal fb i dopiero działa.

Pozostało 580 znaków

2006-11-21 10:59
0
Misiekd napisał(a)

a serwis w ogóle Ci startuje :>

Tak. Procesy chodzą: fb_guard i fb_inet_server

Rafalw. - plik jest ok i nie jest tylko do odczytu. A MKS_Vira nie mam. ALe kombinacje niezłe ;)

Pozostało 580 znaków

2006-11-21 13:11
0

przepisz (albo daj screena) dokładnie komunikat, jaki wywala Ci isql oraz ibexpert


- Ciemna druga strona jest.
- Nie marudź Yoda, tylko jedz tego tosta.
Google NIE GRYZIE!
Pomogłem - kliknij

Pozostało 580 znaków

2006-11-22 13:18
0
Misiekd napisał(a)

przepisz (albo daj screena) dokładnie komunikat, jaki wywala Ci isql oraz ibexpert

Oto komunikat od GSEC(IBExperta nie mam na tym kompie):

C:\Program Files\Firebird\Firebird_1_5\bin>gsec -user SYSDBA -password masterkey -
database "localhost:C:\Program Files\Firebird\Firebird_1_5\security.fdb"

Unable to complete network request to host "localhost".
Failed to establish a connection.
unable to open database

Pojawia się dopiero po kilku minutach.

Pozostało 580 znaków

2006-11-22 16:16
0

zrób ping localhost
a jak będzie ok to telnet localhost 3050 i powiedz co masz


- Ciemna druga strona jest.
- Nie marudź Yoda, tylko jedz tego tosta.
Google NIE GRYZIE!
Pomogłem - kliknij

Pozostało 580 znaków

2006-11-22 16:38
0

U mnie na 1 XP "ping localhost" jest ok, na drugim unable to..., a po ip działa. Spróbuj ip zamiast localhost. A w ostateczności po netbuju:
"//adres_ip/Program Files/Firebird/Firebird_1_5/security.fdb", tylko chodzi d. wolniej i lubi zrywać...

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0