Oracle forms i problem z JInitiator

Odpowiedz Nowy wątek
2011-07-31 15:18
lukasz
0

Witam. Mam roblem z odpaleniem formsow w przegladarce, poniewaz kiedy uruchamiam formularz, przegladarka zwraca blad i zamyka sie. Tak jakby cos bylo nie tak z wtyczka JInitiator
System: win7 x86
Przegladarka: Firefox 3.6
oracle 10i
jinitiator 1.3.22
jdk 1.6.0_16

czesc pliku konfiguracyjnego formsweb.cfg

  1. Page displayed to Netscape users to allow them to download Oracle JInitiator.
  2. Oracle JInitiator is used with Windows clients.
  3. If you create your own page, you should set this parameter to point to it.
    jinit_download_page=/forms/jinitiator/us/jinit_download.htm
    # Parameter related to the version of JInitiator
    jinit_classid=clsid:CAFECAFE-0013-0001-0022-ABCDEFABCDEF
    # Parameter related to the version of JInitiator
    jinit_exename=jinit.exe#Version=1,3,1,22
    # Parameter related to the version of JInitiator
    jinit_mimetype=application/x-jinit-applet;version=1.3.1.22

  4. Page displayed to users to allow them to download Sun's Java Plugin.
  5. Sun's Java Plugin is typically used for non-Windows clients.
  6. (NOTE: you should check this page and possibly change the settings)
    jpi_download_page=http://java.sun.com/products/archive/j2se/1.4.2_06/index.html
    # Parameter related to the version of the Java Plugin
    jpi_classid=clsid:CAFEEFAC-0014-0002-0006-ABCDEFFEDCBA
    # Parameter related to the version of the Java Plugin
    jpi_codebase=http://java.sun.com/products/[...]ows-i586.cab#Version=1,4,2,06
    # Parameter related to the version of the Java Plugin
    jpi_mimetype=application/x-java-applet;jpi-version=1.6.0_16
  7. EM config parameter
  8. Set this to "1" to enable Enterprise Manager to track Forms processes
    em_mode=0

Prosze o jak najszybsza pomoc.

Pozostało 580 znaków

2011-08-05 11:35
0

Hej,
ja używam jinitiatora w wersji 1.3.1.9, i to co piszę odnosi się do tej wersji i bazy 8i, ale myślę, że możesz spróbować tych rad.
W FF został zgłoszony błąd i wtyczka nie działa poprawnie w ff 3.6. Na pewno działa z FF 3.5.1, nie wiem jak w nowszym i zwykle takiego instaluję ludziom, albo każę pracować w IE

Sam proces instalacji w Viście i windows 7 przeprowaedzam tak jak tu:
http://forums.oracle.com/forums/thread.jspa?threadID=548549

"1. You better have the most updated JRE (1.6.0_03) installed in your Vista.

  1. Copy the file, JVM.dll => C:\Program Files\Java\jre1.6.0_03\bin\client\jvm.dll to overwrite the one in your Jinitiator Path, C:\Program Files\Oracle\JInitiator 1.3.1.28\bin\hotspot"

Czyli najpierw zainstalować jre, potem jinitiatora, a potem popodmieniać pliki w jinitiatorze plikami z jre

Pozdrawiam,

edytowany 1x, ostatnio: void-tec, 2011-08-05 11:36

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0