[MSSQL] Problem z połączeniem do bazy MSSQL.

0

Witam, szczerze mówiąc nigdy nie pracowalem na mssqlu, teraz muszę wykonać parę selectów i natrafiłem na problem z połączeniem. przeszukałem już troszkę netu ale jak na razie nic nie pomogło.
Mianowicie mam zainstalowaną bazę MS SQL EXPRESS , do tego serwer Krasnal z php5, używam funkcji mssql_ceonnect ale zwraca blad ze nie moze sie polączyć.

Mssql odpalony prawidłowy, wchodzę przez managera, hasła sprawdzone. Łącze sie zarowno przez 127.0.0.1 jak i NAZWAKOMPA\SQLEXPRESS ale nic. Bład:

Warning: mssql_connect() [function.mssql-connect]: Unable to connect to server: 127.0.0.1:1433 in

Może coś trzeba ustawić w mssqlu ? W czym może być problem?
W php.ini oczywiście mam odznaczona dll-ę php_mssql.dll , nie powoduje to błędów także nie wiem.
Pozdrawiam

0

Wejdz w SQL Server Configuration Manager/SQL Server 2005 Network Configuration/Protocols for <nazwa instancji="instancji"> i wlacz TCP/IP.

Manager laczy sie przez Named Pipes stad on dziala, a php juz nie moze ;)

0
johny_bravo napisał(a)

Wejdz w SQL Server Configuration Manager/SQL Server 2005 Network Configuration/Protocols for <nazwa instancji="instancji"> i wlacz TCP/IP.

Manager laczy sie przez Named Pipes stad on dziala, a php juz nie moze ;)

Niestety wszystko jest ON tutaj podaje screen do konfiguracji tcp/ip

user image
</url>

0

W TCP ports wpisz 1433 (we wszystkie 3). Zakladam, ze w pierwszej zakladce jest Enabled = yes?

0
johny_bravo napisał(a)

W TCP ports wpisz 1433 (we wszystkie 3). Zakladam, ze w pierwszej zakladce jest Enabled = yes?

Tak jest YES, zrobilem ja mowiles i nic to samo.
Mam taki kodzik skomplikowany:

    $SERVER = "MARIUSZ\SQLEXPRESS";
    $ADMIN_NAME = "sa";
    $ADMIN_PASS = "lalalal";
    $DATABASE = "test";

    $Conexion = mssql_connect($SERVER, $ADMIN_NAME, $ADMIN_PASS);

Zamiast hosta juz wpisywalem : 127.0.0.1 , 127.0.0.1:1433 ale dalej nic, jest w tej pierwszej zakladce jeszcze VIA na NO ale nie wiem czy to ma znaczenie , cala reszta na ON.

Dobra już działa, mialem złą wersję biblioteki ntwdblib.dll w katalogu windows/system32

0
Glina napisał(a)

Dobra już działa, mialem złą wersję biblioteki ntwdblib.dll w katalogu windows/system32

Faktycznie, zapomnialem, ze ja tez podmienialem ta biblioteke.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0