problem z socket server i ckient

0

Mam kolejny :) maly problem ... hmm...

Chce zrobic prostego chata na ServerrSocket i ClientSocket i wszystko jest fajnie tekst z kilenta jest wysylany do servera ale tylko gdy server i klient sa uruchomione na moim kompie. Jesli kolega uruchami klienta a ja mam server i probuje sie polaczyc wyskakuje nastepujacy Blad "Asynchromous socket error 10061" co jest grane ?? teraz siedze w pracy i niemam tu Delphi, ale nie pamietam czy tam jest cos do ustawiania synchronizacji przy serverzee i kilencie ??? co powinienem zrobic zeby dzialalo poprawnie w sieci ???

to chyba ostatnie pytanie w tym tygodniu :)

0

mozliwe ze kumpel ma zajety port przez inna aplikacje albo cos takiego. sproboj zmienic port i sprawdzic. jak nie dziala to nie wiem. :( --Vroc
&ltbr&gt&ltDelphi Knight&gt

0

Sciągnij sobie kompomenty INDY i tam masz demo :-)--Lopi22

0

http://216.26.168.92/vbapi/ref/other/winsockerror.html

Wszystkie błędy socketów i ich opis.--Delphi 6
Pozdrowienia{hello} ,
Moderator Imperior

0

ustaw port w serversocket i w clientsocket na ten sam czyli: 1024 lub np. 1025 :]--

0

to nie wina portow probowalem juz z roznymi niskimi i wysokimi zakazdym razem nic z tego nie dzial. Podejzewam ze jest to wina servera. Klientem udalo mi sie polaczyc z innym serverem, chociaz jak odpae go na kompie to port jaki mu przypisze jest otwarty a po zamkneciu servera port gasnie, keszcze tego nie rozwiazalem.

Zciagnolem INDY ale bym musial caly program przebudowac (troche pracy jest) ;(

0

Juz wiem co bylo przyczyna {brawo}
kiedys jak instalowalem ICS i jakies inne komponenty brakowalo mi kilku bibliotek, i winsock wywalal blad. Przypadkiem biblioteki z tymi samymi nazwami znajdowaly sie w jakims komponencie ktory niewiem gdzie i kiedy pobralem. no wiec dlugo nie myslac przewalilem je do \lib\ i zastapilem winsock. Odziwo wszystko sie kompilowalo i dzialalo na LokalHost (znaczy sie na moim kompie) ale w sieci juz byla zwala.
Dzis z samego rana mocno sie wnerwulem chcialem zrobic update Delphi 5 wersja Enterprise 30 MB zajmuje ciagnolem modemem :[[ i dupa zbita wywwala ze Key jest niepoprawny (jasne ze jest niepoprawny bo jakim crackiem potreaktowalem Delphi), to juz byl koniec dobrego samopoczucie. :[ Wywalilem w kosmos Delphi z mojego dysku. Ale popoludniu znowu wziela mnie ochota na rozwiaaznie problemu 100lecia. Zainstalowalem nanowo D5 i pakiet ICS. Odpalam program (jakies male zrgzuty byly ale nic wielkiego) kompiluje ... i co ????

EUREK wszystko dzial (no prawie) jak powinno znaczy sie komunikacja jest. server i client moga sobie poplotkowac :) az sie zyc zachcewa w takich chwilach :)

Troche sie rozpisalem ale jest Git, niewiem czy ktos procz mojej mamy przeczyta tego posta (ale chyba nawet ona nie bo wyjechala na wakcje ;( )

Dzieki wszystkim za rady i zycze wygranych potyczek z Delphi
Niech moc bedzie z Wami :)

0

Zeby klient mugl sie polaczyc z serverem musi byc wpierw uruchomiony server a potem z tym serverem laczy sie klient a nie odwrotnie.....u mnie bylo to samo albo jakis innny problem z portami

0

A ja jeszcze dodam cos: nie połączy się klient z serwer'em jak bedziesz sie laczyl z adresu rutowanego na wewnetrzn czyli np. klient ma adres rutowany np. 217.117.111.1 a serwer 192.168.1.25 to wtedy nie robi...raczej w tym wypadku trzeba wykorzystac to w odwrotna strone lub posluzyc sie pomocniczym serwkiem...ktory bedzie tylko przyjmowal txt i np. klient bedzie sie do niego dolaczal, wtedy jest jeszcze wiecej mozliwosc bo mozna zrobic MEGA CZAT! :)

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0